Question POST issues (slow boot times) ?

Jan 21, 2023
I've recently built a new system (excluding a new GPU) about 4 days ago-
Corsair 4000D Airflow-
AMD Ryzen 7 7700X-
32 GB Corsair Vengeance DDR5 (5600)-
Samsung 980 Pro 2TB M.2 SSD
RTX 2070 Super (from my old rig)
Corsair RM850x 80+ Gold PSU

Although all parts are working, when I power on I'm met with Error lights on the motherboard - these can range from it sitting on the DRAM for more than 10 seconds, VGA for more than 5 seconds and BOOT for more than 10 seconds although it doesn't appear to be consistent with every boot. Eventually it posts and will load into Windows with seemingly no problem, however it won't recognize my SSD as a bootable drive unless I enable CSM support (I turned it off to test and it immediately boots to the BIOS and the SSD does not appear as a bootable drive).

When I booted for the first time I immediately noticed that my graphics card was not being recognized in the BIOS like everything else was. When in Windows it was still not recognizing my GPU and instead was saying 'Microsoft Basic Display Adapter' in Device Manager. I eventually managed to have Windows recognize the GPU after finishing all Windows updates, and installed GeForce Experience and installed the latest driver. However no matter what, the Bootup process is roughly 30 seconds and the GPU is no where to be seen in the BIOS (No graphics related tabs whatsoever, and no mention of an NVIDIA card anywhere in the BIOS).

I have updated the BIOS to the latest version of F3b (previously it was on F1) and have checked all connections of wires like PCIE, ATX, CPU , USB and Fan connections and everything is solid. Performance and temperatures are spot on for what I expected but I'm no expert and i've never encountered bootup issues like these before so any advice is appreciated, thanks!


Oct 10, 2014
Not sure if this will help, but I ran into a slightly similar situation with my 7600x build. I have the same RAM sticks, but with an MSI b650 Tomahawk. First few boots were slow, had trouble finding my NVME drive. After some experimenting, I found that AMD's website states 5200 as the max for my chip.

What seemed to solve my issue: disconnect everything (GPU, drives that aren't the OS, any usb devices besides KB/mouse); install one stick of RAM in A1 and boot into bios (make sure XMP is OFF); if successful, then exit and restart with the second stick added.

For some reason, I could not get the system to work with both sticks at once. But doing one, then adding the second seemed to work. My thought is that 1) It seems that RAM over 5200 might work, but I am not savvy enough to figure it out how; 2) the RAM "training" may have been what started to cause my initial bios/boot issues, but enabling the XMP profile made it highly unstable.
In task manager, select the startup tab.
At the top right there will be a last BIOS time. Mine says 12.3 seconds.

Once you have a successful boot, selecting fast startup will boot a bit faster.
It reads a simple sequential image of the last boot instead of loading individual windows components.

Better yet, do not boot at all.
Instead of shutting down, use sleep to ram(no hibernate)
That puts the pc and monitor into a very low power state, close to full power off.
sleep/wake become a handful of seconds.