Question Problems with Speedtest.net Windows 10 app

KHL

Mar 2, 2019
11
0
10
0
Here's a problem with the windows 10 Speedtest.net app.

This developed in the last couple of days. When starting a test, the ping skyrockets up to 500, then the app shows a transfer rate of 5-10 MP download. This happens despite the speedtest.net server that is selected.

Running the speedtest.net test in a web browser shows download speeds of 240MB and pings of 33ms or so.

Pinging speedtest.net from a Windows 10 command line shows pings of 26ms.

The Windows 10 speedtest.net has been uninstalled and reinstalled several times, and the problem persists.

The problem happens only with the Windows 10 speedtest.net app, and there are no problems when the test is run in a web browser..

Speedtest.net has not responded to requests for help.
 
Last edited:

Ralston18

Titan
Moderator
Three questions:

1) Uninstalled and reinstalled several times; did you download a new copy at any time?

2) What website(s) did you use for the original and any latter downloads.

3) Have you tried any other speed tests in order to compare results?
 

KHL

Mar 2, 2019
11
0
10
0
Three questions:

1) Uninstalled and reinstalled several times; did you download a new copy at any time?

Each time a fresh copy was downloaded.

2) What website(s) did you use for the original and any latter downloads.

The Speedtest .net windows 10 app is available only from the Microsoft store.

3) Have you tried any other speed tests in order to compare results?

That question already was answered in the original post, which noted there were no problems with speedtest.net when run in a web browser. As already noted, only the Windows 10 app from speedtest.net caused problems.
 

ASK THE COMMUNITY

TRENDING THREADS