Question Question about installing the 970 evo plus into a z390-a motherboard.

Neostarwcc

Honorable
Sep 12, 2013
34
0
10,530
0
Okay so I'm finally setting up my computer that I bought last Saturday and I've installed most of it no problem but I've ran into a problem. In the Prime z390-A manual it says that there are two m2 slots. One called m.2_1 that's not behind a backplate and one called m.2_2 that is behind a backplate. When I looked up both slots in the manual it says that the m.2_1 socket supports PCI.E 3.0 x4 and SATA mode m key design and type 2242/2260/2280/ PCI-E and SATA storage devices and it says that if I use this slot I have to enable all SATA devices in the BIOS? What does this mean? So if I want to hook up my other devices like a SATA 6.0 4TB HDD and a SATA 6.0 Bluray burner ...etc than I have to enable them all in the bios somehow?

It also says that the M.2_2 socket supports PCI.E 3.0 x4 m key design and type 2242/2260/2280/22110 PCIe storage devices. But it says nothing about having to enable SATA devices in the bios. So if I stick the Samsung 970 evo PLUS into this slot I don't have to enable my SATA devices? So this slot is where I stick my SSD into right? Or can I install it into the M.2. 1.1 slot too? Does it really matter which slot I stick it into?

I'm sorry for the question I've literally never installed a new SSD in my life (The only ones I ever installed were SATA 3 back in the 120GB 840 evo days) I just don't want to stick it into the wrong slot and potentially fry my SSD or motherboard. Thanks for the help! Oh and if I do end up using the slot with the backplate I have to stick the backplate back onto it right?
 

Neostarwcc

Honorable
Sep 12, 2013
34
0
10,530
0
https://www.asus.com/us/Motherboards/PRIME-Z390-A/specifications/

only if you are using sata type m.2, which 970 evo plus is NOT
so you are fine. every sata is usable
Okay well my video card is blocking the first port so I'll probably use the one with the backplate. I'm going to look up a video on how to install it now. Okay one thing I noticed though after I got my computer to POST. The motherboard isn't reading any of my SATA devices at all. I have to enable them in my bios right? Where do I go to enable that?
 

Neostarwcc

Honorable
Sep 12, 2013
34
0
10,530
0
Right now I just have a 4tb HDD hooked up and a samsung 840 evo 250gb. Until I can figure out how to install the 970 evo after supper. It's looking like I'll have to remove a lot of stuff to take the plate off. I'll read the article you linked though and see.

I have the manual but I can't see where it is in the manual. I think I found a video on how to do it though. The video says we can choose between Raid and Amci mode. I set it to amci mode right? Since I'm installing an SSD and hard drove?
 

ASK THE COMMUNITY

TRENDING THREADS