Question Radeon R9 290 doesn't work after reboot or sleep without a PSU reset ? (solved)

Jun 21, 2021
2
0
10
0
Ran into a strange issue after replacing a motherboard. The system works perfectly the first time it boots after I plug it in. Stable at idle and load, time doesn't matter, temps are good. But as soon as I power down, suspend, or hibernate (not reboot), then next time I start it one of the GPUs (R9 290) doesn't come up. The fans spin 100% and there is no display, and it doesn't show up as a PCI device. This happens every time until I toggle the PSU switch / power. Then it works again the first time, every time I toggle the PSU power.

When its in this state the rest of the computer works completely fine, I have a second GPU, RX 550 that is not affected by this, and so the display goes through that GPU and everything works normally, except its like the R9 290 isn't plugged in.

I messed around with a lot of the BIOS options and after enabling "ErP Ready" it seemed to resolve the issue for power down and hibernate, but it still occurs after suspend, so I'm assuming its some issue that happens when the MB still have some power.

Things I've tried:
Removing everything but the CPU + MB + R9 290, same behavior.
Swapping the PSU, same behavior
Removing and replacing the card when its powered down, still happened
Removing and replugging the motherboard power connector, fixes it similar to toggling PSU

Wondering if anyone has any idea what could be the problem here? Could be a compatibility issue. Doesn't seem to me like it could be a driver / software issue because it happens in the BIOS even if there are no boot drives connected. I really don't want to have to try to find a new GPU at this time, but I guess I could try to just order same motherboard I had before, even though I'd essentially be paying the same price I paid a few years ago to get it - with no upgrade. Hoping there is potentially some power feature or something I could mess with to fix it.

Specs:
Ryzen 5 2600
Corsair Vengeance RGB 2x8GB DDR4 3200MHz C16
MSI x570-a pro (replaced MSI B450 Tomahawk)
Sapphire TRI-X OC Radeon R9 290 - first slot
Sapphire Radeon RX 550 - second slot
EVGA Supernova 850 GA
 

Ralston18

Titan
Moderator
How are you powering down - PSU switch or other hard switch?

Unplugging power cables? Surge Protectors, Power strips... etc.

Do you use the normal Windows shutdown process first before removing power?

My thought is that the GPU drivers, or some other file(s) , have been corrupted.

Just as a matter of elimination, manually download the GPU drivers via the manufacturer's website. Reinstall and reconfigure. [Do not use any third party installers.]

Failing that, try "sfc /scannow" and "dism".

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image
 
Jun 21, 2021
2
0
10
0
Thanks for the reply. So this was actually fixed by updating the MB BIOS to version 7C37vHD. Didn't try this at first because I already had a newish BIOS, but I guess this bug related to an old GPU was fixed sometime in the past 6 months somehow. But everything works fine now with the 290 and x570a pro.
 

ASK THE COMMUNITY

TRENDING THREADS