[SOLVED] Radeon RX 580 stops working for a sec, then the game crashes

May 28, 2020
14
0
20
0
Hello!
So, whenever I play a game, after a while, the game freezes and the screen goes "No Signal". After that 2 things can happen, the screen shows up everything as nothing happened (though the game crashes), or it stays in No Signal and I have to restart the pc.

Here is the thing. even though I play low specs games because I dont want to deal with this, some of those games still make the thing happen (risk and league of legends, for example), though it happening in high spec games it's kind of a given.

My specs are:
Gigabyte GA-H110M-S2H
i5 7600K
RX 580 Sapphire Nitro+
Corsair VS550
1x8GB DDR4 2133mhz
 

Jay_dog

Prominent
Apr 14, 2020
738
104
590
18
What are your CPU temps?

Also adding another stick of the same RAM will put you in Dual Channel configuration and give you a slight boost in performance.
 
May 28, 2020
14
0
20
0
I'm far from beeing an expert in hardware so I couldn't tell you my cpu temps, sorry xD
Any aplication recomendations to see the cpu temps and stress test it?
 

poorbugger

Reputable
Nov 28, 2015
473
64
4,790
10
Yes, everything besides the power suply and the motherboard is second hand
There are many rx580s and rx570s out there being sold second hand, they are normally used for mining. Try to open it up, clean it and apply new thermal paste. Also please download gpuz and screenshot the bios number
 
May 28, 2020
14
0
20
0
Also, my last atempt was to downgrade the driver from the newest one to the one windows installs by default (with DDU)
 

poorbugger

Reputable
Nov 28, 2015
473
64
4,790
10
The bios seems fine, try opening the gpu. It's quite easy and there are guides on youtube on how to do it. You can get some thermal paste like thermal grizzly kryonaut or artic MX-4. You should also get arctic clean to clean up the old thermal paste
 
May 28, 2020
14
0
20
0
Update: I couldn't open it up

The previous owner must have opened it before and left a screw with it's head completely obliterated, so the screwdriver does nothing to it and thus I can't open the shroud

Still I made a test and the gpu never went higher than 70C. Could it be a problem with the drivers or any other component in the pc?
 
May 28, 2020
14
0
20
0
It did it again while playing The Binding of Isaac Afterbirth and having a youtube video in the background. I had to restart the pc, but before that and while the screen showed "No Signal" I could hear the youtube video playing
 
May 28, 2020
14
0
20
0
Bit of a late update but, i've been playing world of warcraft lately and it seems to trigger this effect pretty frecuently.
The scree randomly prompts "No Signal" and when it comes back wow freezes for a moment and then resumes playing, but the battle.net launcher crashes.
I've also checked temps and they max at 75C for the gpu and 64C for the cpu
 
Last edited:

tennis2

Honorable
Sounds like classic driver crash. First thing to try is a different driver version. If that doesn't help, then I usually get those when a custom voltage profile isn't 100% stable. The black screen is the driver crashing and re-applying the Auto settings.
 
May 28, 2020
14
0
20
0
I installed the latest, and with the default config I still get this happening.
I'm going to try to underclock it through adrenalin

(Though the default config was higher than the specifications of the gpu in the official amd webpage)
 
May 28, 2020
14
0
20
0
It's hard to say but I think underclocking didn't work, because Adrenalin keeps reseting to default even when my screen didn't go black, so when it does go black, Idk if the setings were the default or the underclocked settings

I played the other day and max temps were 74C, whats the maximum temperature it should have?
 

King_V

Distinguished
I wonder if the power supply is at issue. Corsair has some good PSUs, but with the VS, if using an add-in video card, especially a demanding one like the Nitro+ version of the RX 580, you're going to run into trouble eventually.

I would say get a better PSU. Corsair CX, though I'd probably prefer TX or RM. Prices are kind of nuts right now, though.
 
May 28, 2020
14
0
20
0
I wonder if the power supply is at issue.
I've been playing lately with the power limit at -20% and keeps happening

Wild question: Could it be because of ram issues? I've been having some nasty bsod relating memory management and non paged files and I wonder if it is also messing with the graphics card
 
May 28, 2020
14
0
20
0
Certainly could be.
Last week I bought a 16GB ram stick that I replaced for the 8GB one I had installed and the issue is gone!

Thanks to everyone who spent their time to answer this post and teaching me stuff in the way. I wish you all a nice day.
 
May 28, 2020
14
0
20
0
FYI you're leaving noticeable performance on the table by using a single stick of RAM.
I know but the cpu cooler covers one of the slots and the 8GB stick has proven to be defective.

Also would I get dual channel performance with two sticks of different sizes?
 

ASK THE COMMUNITY

TRENDING THREADS