Question RAM DMA test failure - cause for concern?


Oct 5, 2002
I have a Dell Precision T3610

It's a Xeon E5 1620 v2 system with 16GB of RAM in a 4x4GB configuration operating at Quad Channel, the RAM is DDR3 EEC.

I have been hitting my memory limits recently and managed to get a good deal on a used 8x16GB set, the maximum amount of memory the system supports.

Installing it was a pain, since my system came with these apparently optional air ducts that go over the RAM ports, and the only way to take those off is to remove the entire optical drive bay first, it took a bit to replace all the RAM.

So the first thing I did was run Memtest86 to make sure it all works correctly in my system. After several hours I went to sleep, when I came back I saw that it had literally millions of errors, but all of them were at the same address from the same one test, which Memtest86 even lists was a new "(experimental) test:


I tried to Google about this, and found that the people behind Memtest86 found that doing direct DMA access without the CPU found some errors in modules that never showed errors before, so they added this new experimental test. I also saw that many people were having issues with this test and only this test failing, some even at the same address ranges as me. And now, it seems that the latest version of Memtest86 still has this test, but it's disabled by default. When I tried the latest Memtest86 that had the DMA test disabled by default it passed.

I also ran the latest beta of Memtest86+ and Prime96 in Blend mode and got no errors.

Should I be worried that there could either be some fault with the RAM or my system not being compatible with it? Or is this test likely not reliable and I should ignore it?

Also, when I took out the 4x4GB RAM sticks, I noticed that they all had heat spreaders... even though they were different brands. The new RAM is just the bare sticks with no heat spreaders. Should this be a cause for concern?