Question RAM suddenly not compatible

Feb 8, 2022
3
0
10
Hello

My RAM upgrade (bellow) worked for a few days on my old motherboard, then all of a sudden the computer would not start any more. On rare occasion I could still get the initial UEFI splash screen, nothing more.

So I keep thinking and thinking: what kind of defect could make the RAM work for just 1 day ? Any ideas ?

Clearing CMOS and replacing the old battery did not work. Trying one RAM stick at a time did not work. I checked the RAM sticks are seated in the slots and both clamps click (the sticks are hard to fit in the slots). If I visually line them up with the old RAM, and check for size differences, nothing is wrong.

Putting back the old memory makes the motherboard work as expected again.

So maybe somehow the motherboard automatically enables the higher 1600 MHz memory speed, despite the CPU not supporting it ? Is that possible ? But how do I turn down RAM speed, since I can not enter UEFI ?

If I just buy a new CPU (i7-4790K), would it solve the problem ?

How could I re-write the SPD to lower the RAM frequency ? Do I need a payed app, or can I use Linux ?

There is a minor BIOS update from Asus for my MB, but updating is not trivial for me since I modified my BIOS to add the NVMe module (by a stroke of luck), by following a forum post that I do not remember now. I use an NVMe SSD to boot Windows, connected to the PCIe slot with an adapter from M.2 to PCIe. The MB predates NVMe drives, so I had to unpack the BIOS file and add the NVMe module from Asus to it. I should be able to do the same again, but it's been a long time. The new BIOS version only says
"Improve system compatibility. Support ALC897 audio codec" Could this BIOS update fix my RAM issue ?

Motherboad: Asus H81M-K

Processor: Intel Pentium Celeron G3220 (dual-core with HD Grapchics)
https://ark.intel.com/content/www/u...entium-processor-g3220-3m-cache-3-00-ghz.html

New RAM: Patriot Viper 2x8GB DDR3 PC3-12800 1600MHz, 9-9-9-24 1.5V PV316G160C9K
https://assets.website-files.com/5cdb2ee0b102f96c3906500f/5dd6c45aed1853e2809f0eed_PV316G160C9K Sku Sheet_Copyable 071019.pdf

Old RAM: 1x4GB Kingston 4GB (PC3-10600 ) 1333MHz, 9-9-9-24-33 1.5V
https://www.kingston.com/datasheets/kvr13n9s8_4.pdf

Gigabyte AORUS RGB M.2 NVMe SSD 512GB:
https://www.gigabyte.com/ro/Solid-State-Drive/AORUS-RGB-M2-NVMe-SSD-512GB#kf

Toshiba HDD 1TB DT01ACA100
https://toshiba.semicon-storage.com...nal-specialty/pc/articles/dt01aca-series.html

Asus 24x DVD-RW optical drive DRW-24F1ST:

No discrete video card.

Again, the RAM worked for about 1 day... unblievable !

--
Thank you,
Adrian Constantin
 
Last edited:

MansterZQ

Reputable
Jun 12, 2020
50
1
4,535
First you can change the cpu, because sometimes if you changing the ram or something, the internall RAM Controller maybe will damaged, so first change cpu, if this will doesn't help, you must change the bios and it will help.

Your processor dont must support higher clocks of ram because of XMP ;)

In old ram 100% work ? how you add the ram?
 
Feb 8, 2022
3
0
10
I have to buy the new CPU for this, so I would like to know if this what I must do now, given the situation.

You mean update the BIOS, right ? I am working on it, trying to remember the steps needed to mod the new BIOS and add the NVMe module again. Hope I don't break anything :)

I know XMP should not be the default, but does 1600 MHz mean XMP ?

Old RAM is working 100% with no issues. All I had to do is put it back, into the first slot (next to the CPU). Do you still think the memory controller could be damaged ?
 
Feb 8, 2022
3
0
10
Updating BIOS from 3602 to 3604 (latest) did not help. I had a feeling the heatspreader was preventing the DIMM from fitting properly in the socket, but removing it did not help either. Selecting a memory frequency of 800MHz in the BIOS before inserting the new DIMMs did nothing as well.

So I think this must be a hardware failure, but what would make both DIMMs stop working ?
 

TRENDING THREADS