Question RAM's Official spec is 2666MHz but it's running at 1066MHz under max bandwidth?

Nov 14, 2019
13
1
15
0
I'm a new member to Tom's Hardware but I've come across Tom's Hardware a lot in my PC days. I have abandoned computers for almost a whole decade but I'm back at it...(this is my 2nd year back into the roots)

I have a newly built pc, this would be my third build in my lifetime. I have a Corsair RAM the stability is good. I ran it in Windows Memory Diagnostic. The frequency speed is not good though. In BIOS/UEFI I forced it to set it at 2666MHz but it shows that the frequency max bandwidth is at 1066MHz in CPU-Z. But in BIOS/UEFI it was originally set the speed at 2133MHz not the advertised frequency.

I don't overclock my computers.

My spec is

AMD Ryzen 3 1200: https://www.newegg.com/amd-ryzen-3-1200/p/N82E16819113446
ASUS ROG STRIX B450-F Gaming: https://www.newegg.com/asus-rog-strix-b450-f-gaming/p/N82E16813119140
CORSAIR Vengeance 16GB LPX DDR4 2666MHz: https://www.newegg.com/corsair-16gb-288-pin-ddr4-sdram/p/N82E16820233943
Samsung Evo 970 Plus 500GB NVME SSD: https://www.newegg.com/samsung-970-evo-plus-500gb/p/N82E16820147742
CORSAIR PSU CX650: https://www.newegg.com/corsair-cx-series-cx650-650w/p/N82E16817139200
And the old GPU is a PCI-E 2.0 ZOTAC GeForce GT 730 DDR3 4GB(model with no fan, just a reliable heatsink) I don't think newegg has this anymore.


CPU-Z Data (sorry the forum wont let me attach the image)
Memory: View: https://imgur.com/HJQhtnU

SPD:
View: https://imgur.com/AdtL11f



Need help, thank you in advance.
 
Last edited:
Nov 14, 2019
13
1
15
0
Hello Boju,

Ok there is no docp option in BIOS. I just swapped the ram into the A2 slot. I still forced BIOS/UEFI to run at 2666MHz instead of auto. The specs are the same in A2 under CPU-Z

Thanks,
HoneyBadger_xyz
 
Nov 14, 2019
13
1
15
0
Hello Boju,

Okay that clarifies the bandwidth thinging, I found the docp option i just enabled it to docp standard and set ram frequency on auto but now in the CPU-Z in under Memory-DRAM frequency says its 1064.1MHz most of the time but i see this value changing in CPU-Z so I assume the speed is in variable mode?

Thanks,
HoneyBadger_xyz
 

boju

Champion
The reason i asked you to swap ram slots earlier is the 2nd/4th slots are primary, these are populated first. Same for all boards but Ryzen specifically, can run into frequency issues, though i think it's more of an issue if running faster ram. Thought i'd try get that niggle out the way.

 
Reactions: honeybadger_xyz

boju

Champion
So I should leave my RAM at A2 if that's what you're saying?
Yes, leave it in A2 slot.

The timings match now to 16 18 18 18 35. Not sure why tRc is a little higher still at 62, might not matter but can try change it manually in dram timing control (at 1:50 in video) for tRC to 53 and see if it fixes fluctuating Northbridge. Not sure why that is though, could be just a software bug. Perhaps try Ryzen Master.
 

boju

Champion
Sorry had a phone call.

Ryzen Master is reading properly at 1333 so that's good. I don't think there's a problem. If it don't bsod on you, think you're good ;P Think Cpuz is just buggy with Ryzen.

Cpuz reading memory speed at 1330.2MHz, naw .2 isn't times by 2.

If you want to try manually set ram you'll need to set ram timings yourself, exactly how docp put it in the dram timing control page.
 

boju

Champion
Be interesting to see what happens. Have read sometimes ram set manually can solve issues for some particular ram. But in saying that, that's if there was a problem, it's only minor for the moment. Whether there be any difference or not, guess we'll see.

Good luck.
 
Nov 14, 2019
13
1
15
0
Hello,

It frozen twice on me while in Linux(Ubuntu 19.04 - I know.. I'm just working into it) a day or two apart. It's less than a week and a half old. This new computer have not been frozen with Windows 10 Pro yet or BSOD(day4). Freshly installed and everything set to normal settings.

I'm taking computer assembly class and building with it all of your help is an honor to this new build.

I figured it out now, I have docp standard on, I can actually edit it( the | thing is not there nor blinking, just to tell anyone that its editable or not frozen. lol

Anyways, the auto->53 at tRc. With Auto->"D.O.C.P. standard" on

View: https://imgur.com/pzf2WMz


View: https://imgur.com/CcEkPM6


View: https://imgur.com/l2D3yub


This is the first I've set timings in BIOS/UEFI. It's a little quicker.
Thanks for all the help, Boju.

Thanks,
HoneyBadger_xyz
 

boju

Champion
You're welcome and gnight.

When you can, help me understand, im a bit confused. When was it freezing? Was it since you made the changes or prior?

If it was prior, having your ram in A1 could have been unstable. Docp/timings has a lot to do with it but think having ram in the right slots helps a lot too.
 
Last edited:
Nov 14, 2019
13
1
15
0
You're welcome and gnight.

When you can, help me understand, im a bit confused. When was it freezing? Was it since you made the changes or prior
It was like freezing just sitting not working even set on for couple of hours then it'll freeze. No dual boot, no virtual machines(yet) but it was freezing before I came here. While ram was in A1 slot but it was Linux by itself first for a week and then its Windows.
 

ASK THE COMMUNITY

TRENDING THREADS