Realtek HD Audio - No Sound After Idle For 5 seconds

Status
Not open for further replies.

Rainzord

Reputable
Aug 18, 2014
39
0
4,560
5
Hello there.

Recently I installed Harman Kardon's Soundsticks unto my PC.
The problem I'm going to describe started from the moment I installed the new Soundsticks.

What happens, is after some time when I don't touch my PC (5 mins? not sure), sounds will cease working, unless I "wake" it back up by trying to play sounds. Then, it takes about 5 seconds for the sound to come back up.

This is extremely annoying - and frustrating. I had a similar problem with my Keyboard, where after 10 seconds if not touching it - it "turned itself off", and when I reclicked it, it continued working again. I fixed that problem by disabling power management for the keyboard.

Sadly! I cannot find, anywhere, any option in device manager or anywhere else, an option to disable Power Management, which I suspect is causing my speakers to not work after I leave my PC alone for a bit.

I'm using my PC for alerts sometimes, which is extremely annoying, because since the PC was idle, the alert sound will not pop off because of this annoying bug.

Please help me!
 
Hi,

Please do try changing this settings from Power Options that may help.
- Open Power Options then click on Change Plan Settings then Change Advanced Power Settings.
- Expand Hard Disk then set Turn off Hard disk after to NEVER.
- Expand Sleep and set Allow hyrbid sleep to OFF.
- Set Hibernate after to NEVER.
- Do also set Sleep Mode to Never.
- Click Apply and OK then test it again and see if the same problem will persist or not.
- If all these will not work, last option would be to reinstall Windows.
- If it doesn't work please do also try to uninstall/reinstall the Sound card driver.
- Go to Device Manager and uninstall the Sound card driver.
- Once uninstalled download and install the latest driver from the manufacturer site.
- Reboot the PC again once the latest driver has been installed.
- If all these will not work I would also suggest doing a clean install Windows.
 

Rainzord

Reputable
Aug 18, 2014
39
0
4,560
5
Thank you for your tips.

I tried all those tips - except for uninstalling and reinstalling windows clean. I really do not think that this issue justifies a clean install of windows from 0... Seems a bit of an overstretch. Especially since I believe, and maybe someone knows, whether there is a registry entry that allows to turn off power management for Harman Kardon or the Realtek audio files.
 
Feb 1, 2020
1
1
10
0
A bit late in the game here but hopefully this will help anyone with the same issue. This is for NVIDIA but the registry hack will work with most. After putting up with this annoying issue for 6 months, doing this step worked for me.

Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e96c-e325-11ce-bfc1-08002be10318}\xxxx\PowerSettings

Where 'xxxx' is one of keys which contains DriverDesc value 'Nvidia High Definition Audio'. (Mine was '0000')

Note: There may be multiple ones containing PowerSettings, for example 'Realtek High Definition Audio'. Do not change those.

Within PowerSettings, You'll find there are three binary values and set them to:

ConservationIdleTime = ff ff ff ff;

IdlePowerState = 00 00 00 00;

PerformanceIdleTime = ff ff ff ff.

Default values are all 00 00 00 00 which disables power settings, but driver somehow overrides it with 0a 00 00 00 which is 10 seconds (0x0a = 10) and is by default in driver.

Reboot.
 
Reactions: Whiskeyjack72
May 13, 2020
1
0
10
0
A bit late in the game here but hopefully this will help anyone with the same issue. This is for NVIDIA but the registry hack will work with most. After putting up with this annoying issue for 6 months, doing this step worked for me.

Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e96c-e325-11ce-bfc1-08002be10318}\xxxx\PowerSettings

Where 'xxxx' is one of keys which contains DriverDesc value 'Nvidia High Definition Audio'. (Mine was '0000')

Note: There may be multiple ones containing PowerSettings, for example 'Realtek High Definition Audio'. Do not change those.

Within PowerSettings, You'll find there are three binary values and set them to:

ConservationIdleTime = ff ff ff ff;

IdlePowerState = 00 00 00 00;

PerformanceIdleTime = ff ff ff ff.

Default values are all 00 00 00 00 which disables power settings, but driver somehow overrides it with 0a 00 00 00 which is 10 seconds (0x0a = 10) and is by default in driver.

Reboot.
Hi, I'm having the exact same issue and tried all the above, inlcuding this registry change for the realtk HD audio entry but it hasn't helped unfortunately.

Its becoming a real nuisance and it's been this way with two PCs now.
 
Aug 12, 2020
1
1
15
0
Hi, I'm having the exact same issue and tried all the above, inlcuding this registry change for the realtk HD audio entry but it hasn't helped unfortunately.

Its becoming a real nuisance and it's been this way with two PCs now.
I found the solution regarding the idle time out. In my situation, the driver disconnects after 10 seconds of no sound. This is because the morons that code for Microsoft are lazy fools that have no real world experience. They are Millennials that see most people as "tablet" or "smartphone" people. Them coders do not seem to understand that laptops are for working people that are not playing candy crushes.

For some ignorant reason, Windows must now be getting some level of constant signal in order for an audio output to constantly stay on. Unfortunately, the ignorant coders use white noise believe it or not. White noise is very bad for anyone working in audio/video production, and like I said, the coders have no real world experience because they spent their youth playing games instead of working.

The first thing to understand is that Windows 10 is now labeling auxiliary jacks (3.5mm) on devices as "headphones",... instead of "AUX" like it should be. This throws users of less experience way off. HDMI port is called "HDMI", USB is called "USB", so why are they calling auxiliary "headphones". The morons that made such a decision never had it occur to them that people would desire to connect their laptop to a stereo via aux. These coders have a smartphone and wireless point of view, a millennial pov.

  1. - Click that cog within the start menu to enter settings
  2. - settings
  3. - sound
  4. - input
  5. - make certain that "Stereo Mix (Realtek(R) Audio) is selected
  6. - device properties
  7. - additional device properties
  8. - listen
  9. - check "listen to this device" and "continue running when on battery power"
  10. - levels tab
  11. - set to "0"
For fun, turn the level to 100% during step 11 and you can hear the white noise. How ignorant eh? Why should an audio driver need a constant interfering signal to remain on? Windows 10 is garbage coded by people that needed boot camp or two years in the military. I never would have discovered this flaw if it was not for the fact that every time the idle cutoff kicked in, I heard a humm/buzz from my stereo from a ground loop and grounding issue. An aux cable needs to be grounded in order to get a clean signal. It only gets properly grounded when the aux port on the laptop is active and grounding the cable. So when the idle timeout happens, bye bye grounding, and some people will notice it if their stereo and laptop are connected to the same power source within a home which causes each ground to build off each other resulting in a humm/buzz. Windows keeps getting worse with each build.
 
Reactions: Whiskeyjack72
Status
Not open for further replies.

ASK THE COMMUNITY