Question Recovering Raid5 array

reveille0

Distinguished
Oct 18, 2011
3
0
18,510
0
I had a HDD failure on my raid array.
Implemented via a LSI 3ware 9650se controller.
I have 4 drives.
Drive #2 failed. ("p1")
So I replaced it with a new one but before I could integrate it into the array Drive #4 ("p3") keeps getting assigned to a different imaginary array that my controller keeps making up.
I've tried to remove Drive 4 from this imaginary array and the command works.
The imaginary array disappears.
But so does Drive 4.
So I rescan the controller hoping it can recognize Drive 4 again and it does but it automatically creates a second array and assigns it.
I'm stuck in a Catch-22. Has anyone else run into something similar before? Any advice? I've tried messing around with it through the gui and cmd prompt.



 

popatim

Titan
Moderator
Have you tried wiping the drive?

I suspect that the drive is used and was formerly in raid The controller or OS is picking up the raid info and automatically importing it.

its possible the LSI has a second raid setup on it also and P3 is part of it.
 

reveille0

Distinguished
Oct 18, 2011
3
0
18,510
0
Have you tried wiping the drive?

I suspect that the drive is used and was formerly in raid The controller or OS is picking up the raid info and automatically importing it.

its possible the LSI has a second raid setup on it also and P3 is part of it.
Wiping the drive would be a last resort. So there are 2 drives that I am trying to fix. 1 drive failed and I unplugged it and replaced it. Another drive that decided to take a stroll and start its own array. I need to guide the wondering drive back into the array its suppose to be in and then rebuild the hot swapped drive. The controller detects that the one drive was in an array before because it is suppose to be apart of the array; not in a separate one.
 

ASK THE COMMUNITY

TRENDING THREADS