Question Reinstalled OS, fully updated, replaced hardware; still BSoD.

Aug 14, 2020
3
0
10
0
Hello there Hardware peeps!
Got a mystery to be solved if you're up for a challenge.

Several months ago I fixed up an old FX Processor Windows PC to working order.
It worked A-Okay for over a month.

Then my boyfriend decided to upgrade to a Ryzen Processor as he wanted a stronger CPU for new games.

I was unaware Windows 7 didn't have USB compatibility with most Ryzen boards, so we upgraded to Windows 10 after finding this out the hard way!😊

It worked fine for a few weeks, then we started getting BSoDs.
They'd get more and more frequent until I would be forced to reinstall Windows.

This would happen repeatedly.

At random times, but also almost always when signing into Steam and trying to install Avira Antivirus


Unexpected Kernel mode trap (very common)
Security kernel failure
Driver verifier detected violation
System Service Exemption
Irql not less or equal (most common)
System thread exemption not handled
Attempted execute of nonexecute memory
Special pool detected memory corruption
Bad system config info (either caused by me or problem festering)
Memory management
Pagefault in nonpaged area
Apc index mismatch
Driver overran stack buffer
Kmode exception not handled
Kernel Mode Heap Corruption (kinda new? happened once)

Eventually after learning a bit(and reinstalling Windows at least six times, at least two being clean installs), I managed to get the system running a lot more stable.
Avira is installed, and Steam can run.
In fact, it even seemed to be working fine for just over a week.
But now it's BSoD-ing regularly, especially when my BF plays League of Legends.

Every time the system crashes. I run sfc, dism, chkdsk and startup repair.
Startup repair almost never finds an issue, but the other three do, say a third of the time.
I've run memory check too, which hasn't found an issue with any of my RAM.


I've replaced every component(MB, RAM, PSU, GPU) at least once except the CPU and Blu-Ray drive, fully updated Windows and my Drivers, installed Windows to both an HDD and SSD. I fully updated the BIOS on the first Ryzen MB, but not the most recent MB.

Nothing has solved the problem.
This has been going on for months, we have a replacement CPU on the way, but I really am at my wits end. Is it the Windows installation? It seems to be a US installation, on a UK PC...doubt that matters though...

Any help would be appreciated. I am out of ideas, and have dumped too much £ into this.:disrelieved:

Windows 10 Home Version 10.0.19041 Build 19041 (x64)
Processor Ryzen 3 3100
RAM Kingston Hyper-X Daul Channel 16GB
Motherboard ASUS TUF B450M-PLUS GAMING
GPU Sapphire Pulse Radeon RX 580
SSD Crucial BX500 240GB
HDD Western Digital Blue 1TB (WDC WD10EZEX-60WN4A1)
Blu-Ray ?(Generic?)
PSU Corsair CX600

If you need more information, please ask.
Though a warning, I'm not exactly a power user.:sweatsmile:

(Edit: also cleaned everything with WD-40 Contact cleaner and compressed air. Made sure all connections weren't loose)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS