Question RTX 2070 SUPER stutter lag/freeze lag

Feb 28, 2020
4
0
10
0
Hello. I need some help with stutter lags and micro freeze lags in CS:GO. The FPS is fine (250+ all the time) and the ping is low. It lags in PUBG also. And I've tryed almost everything. I will make a list of the stuff a tried to make the game run smooth. I've been reading all over the internet about solutions and the only usefull stuff I found was that other people with the same Graphics Card have the same issues (ASUS GeForce RTX 2070 SUPER DUAL EVO).

I have updated the NVIDIA and Sound Drivers. I have reinstalled the game and verifyed integrity of game files. All Core's in the CPU is Enabled and got a temp around 30-50C. Core parking, Frequency scaling and Turbo boost is at 100% and the System power plan: High Preformance. Nothing wrong with the RAM. I have turned off the XBOX sh*t stuff and unchecked the full screen optimazation in CS:GO compatibility.

I have done more stuff too but I don't remember all at the moment. Thanks 4 the help guys.

PC:

Graphics Card - ASUS GeForce RTX 2070 SUPER DUAL EVO

CPU - Intel Core i7-9700KF | CPU Cooler - CM Masterliquid ML240L

Motherboard - ASUS ROG Strix Z390-F GAMING, S-1151

Memory - HyperX Fury RGB DDR4 2666MHz 16GB

Power supply - Corsair TX650M, 650W PSU

Case - Phanteks Eclipse P400A RGB BLACK

Hard drive - Kingston A2000 1TB NVMe M.2 SSD



NVIDIA:

MANAGE 3D SETTINGS |

Image Sharpening - Sharpening Off, Scaling Disabled

Ambient Occlusion - Off

Anisotropic Filtering - Off

Antialiasing - Off

Antialiasing Gamma Correction - On

Antialiasing Mode - Off

CUDA GPUs - All

DSR Factors - Off

Low Latency Mode - On

Max Frame Rate - Off

Monitor Technology - Fixed Refresh

Multi-Frame Sampled AA (MFAA - Off)

OpenGL Rendering GPU - Auto-Select

Power Management Mode - Prefer Maximum Performance

Preferred Refresh Rate (AOC 2590G4 - Highest Available)

Shader Cache - On

Texture Filtering Anisotropic Sample Optimization - On

Texture Filtering Negative LOD Bias - Allow

Texture Filtering Quality - High Performance

Texture Filtering Trilinear Optimization - On

Threaded Optimization - Auto

Triple Buffering - Off

V-Sync - Off

Virtual Reality Pre-Rendered Frames - 1

Virtual Reality Variable Rate Super Sampling - Off

SET UP G-SYNC |

G-Sync is turned off.

ADJUST DESKTOP SIZE AND POSITION |

I have selected FULL-SCREEN in Scaling mode.

Preform scaling on GPU and I have check the bar with OVERRIDE THE SCALING MODE SET BY GAME AND PROGRAMS.

Resolution is set on 1920x1080 and the refresh rate is on 144hz.



CS:GO:

VIDEO SETTINGS | RES: 1600x900

Global Shadow Quality - High

Model / Texture Detail - Low

Effect Detail - High

Shade Detail - High

Multicore Rendering - Enabled

Multisamling Anti-Aliasing Mode - None

FXAA Anti-Aliasing - Disabled

Texture Filtering Mode - Bilinear

Wait for Vertical Sync - Disabled

Motion Blur - Disabled

I have tryed other resolutions/aspect ratio and the lag doesn't feel as bad in 4:3 aspect ratio.
 

boju

Polypheme
Ambassador
Have you tried other games?

Monitor cpu usage with Msi AB while you play. Check the cpu usage field without a number in AB to view total cpu usage.

Have you tried DSR, increasing resolution to ridiculously high levels to see what happens? Frame rates can have an affect on cpu usage so im thinking possibly low res could be requesting too many frames from the cpu. Doubt it with that cpu, but see.

Also, i presume that monitor is 60Hz? Fps can feel off if not in sync. Try cap the frame rate to 60, or possible 120 and see how it feels.

Do monitor cpu usage though and try not run too much background stuff if aiming for such a high frame rate so cpu can focus more on feeding the gpu.
 
Feb 28, 2020
4
0
10
0
Have you tried other games?

Monitor cpu usage with Msi AB while you play. Check the cpu usage field without a number in AB to view total cpu usage.

Have you tried DSR, increasing resolution to ridiculously high levels to see what happens? Frame rates can have an affect on cpu usage so im thinking possibly low res could be requesting too many frames from the cpu. Doubt it with that cpu, but see.

Also, i presume that monitor is 60Hz? Fps can feel off if not in sync. Try cap the frame rate to 60, or possible 120 and see how it feels.

Do monitor cpu usage though and try not run too much background stuff if aiming for such a high frame rate so cpu can focus more on feeding the gpu.
I have only tried CS:GO, PUBG and OVERWATCH. It's the same issue with all of them.

The total CPU and GPU usage in CS:GO with my standard settings.
CPU: 35%, but CPU4 is at 75%.. The other ones between 25-40%.
GPU: 32% and the heat 40'C.

I have tried diffrent settings in NVIDA Control Panal. And my monitor is on 144hz and I'm using DisplayPort.

Thanks for replying.
 

boju

Polypheme
Ambassador
From installing Windows fresh on this hardware, installing chipset driver and installing gpu drivers from Geforce, this really shouldn't be happening.

If OS drive was from another computer, has this been done? Windows a clean install? Not reset?
 
Feb 28, 2020
4
0
10
0
I bougth this PC two weeks ago from Komplett. Komplett installed Windows and I have been updating all the drivers. But I can try to reinstall Windows.
 

boju

Polypheme
Ambassador
Yeah dude, worth a try reinstalling Windows.

 
Feb 28, 2020
4
0
10
0
I've tried DDU and installed new NVIDA-drivers, but that didn't help.
But thanks for the help Boju.

Tried to reinstall Windows, but it did'nt help.
 
Last edited:
May 18, 2020
1
0
10
0
Hello. I need some help with stutter lags and micro freeze lags in CS:GO. The FPS is fine (250+ all the time) and the ping is low. It lags in PUBG also. And I've tryed almost everything. I will make a list of the stuff a tried to make the game run smooth. I've been reading all over the internet about solutions and the only usefull stuff I found was that other people with the same Graphics Card have the same issues (ASUS GeForce RTX 2070 SUPER DUAL EVO).

I have updated the NVIDIA and Sound Drivers. I have reinstalled the game and verifyed integrity of game files. All Core's in the CPU is Enabled and got a temp around 30-50C. Core parking, Frequency scaling and Turbo boost is at 100% and the System power plan: High Preformance. Nothing wrong with the RAM. I have turned off the XBOX sh*t stuff and unchecked the full screen optimazation in CS:GO compatibility.

I have done more stuff too but I don't remember all at the moment. Thanks 4 the help guys.

PC:

Graphics Card - ASUS GeForce RTX 2070 SUPER DUAL EVO

CPU - Intel Core i7-9700KF | CPU Cooler - CM Masterliquid ML240L

Motherboard - ASUS ROG Strix Z390-F GAMING, S-1151

Memory - HyperX Fury RGB DDR4 2666MHz 16GB

Power supply - Corsair TX650M, 650W PSU

Case - Phanteks Eclipse P400A RGB BLACK

Hard drive - Kingston A2000 1TB NVMe M.2 SSD



NVIDIA:

MANAGE 3D SETTINGS |

Image Sharpening - Sharpening Off, Scaling Disabled

Ambient Occlusion - Off

Anisotropic Filtering - Off

Antialiasing - Off

Antialiasing Gamma Correction - On

Antialiasing Mode - Off

CUDA GPUs - All

DSR Factors - Off

Low Latency Mode - On

Max Frame Rate - Off

Monitor Technology - Fixed Refresh

Multi-Frame Sampled AA (MFAA - Off)

OpenGL Rendering GPU - Auto-Select

Power Management Mode - Prefer Maximum Performance

Preferred Refresh Rate (AOC 2590G4 - Highest Available)

Shader Cache - On

Texture Filtering Anisotropic Sample Optimization - On

Texture Filtering Negative LOD Bias - Allow

Texture Filtering Quality - High Performance

Texture Filtering Trilinear Optimization - On

Threaded Optimization - Auto

Triple Buffering - Off

V-Sync - Off

Virtual Reality Pre-Rendered Frames - 1

Virtual Reality Variable Rate Super Sampling - Off

SET UP G-SYNC |

G-Sync is turned off.

ADJUST DESKTOP SIZE AND POSITION |

I have selected FULL-SCREEN in Scaling mode.

Preform scaling on GPU and I have check the bar with OVERRIDE THE SCALING MODE SET BY GAME AND PROGRAMS.

Resolution is set on 1920x1080 and the refresh rate is on 144hz.



CS:GO:

VIDEO SETTINGS | RES: 1600x900

Global Shadow Quality - High

Model / Texture Detail - Low

Effect Detail - High

Shade Detail - High

Multicore Rendering - Enabled

Multisamling Anti-Aliasing Mode - None

FXAA Anti-Aliasing - Disabled

Texture Filtering Mode - Bilinear

Wait for Vertical Sync - Disabled

Motion Blur - Disabled

I have tryed other resolutions/aspect ratio and the lag doesn't feel as bad in 4:3 aspect ratio.
Hi there
Hope you're well and safe.

I have the exact same issue and I tried every trick in the book. I've hit a stone wall now and cant think of any other thing to do.
Were you able to solve the issue?

This issue has really taken the wind out of me.. Its a defeating sort of feeling.

Please let me know of your experience and any advise to solve this.
Much appreciated

Cheers
Mufi
 

ASK THE COMMUNITY