Question rx 580 no signal?

May 21, 2020
6
0
10
0
Hi all.

I bought a new system over a week ago.
rx 580 8 gig.
2 x 8 gig mem.
msi tomahawk max motherboard.
500 gold plus power supply.
Windows 10 pro.
Ryzen 5 3600 cpu.

Nothing but booting errors?
After installing windows 10.
Everything is fine untill actually windows 10 loads.
After a few mins i get a no signal error?
It is windows installing some amd driver.
I goto device manager via safe mode and roll back drivers.
Thankfully it comes back on.
Windows loads and i goto amd website, download latest drivers and as they are installing.
It gets to near 70% install and just hangs goes to no signal error again?
Go back to safemode, roll back drivers and thankfully win 10 loads again?
I have checked device manager and there is alot of things with caution signs but after downloading windows 10 latest updates they are now removed.
Any ideas anyone please?
Had the pc nearly 2 weeks now and have not been able to use it correctly?
The amd drivers simply will not install on this rx 580 8 gig card no display error every times.
A few weeks ago i got all sorts of errors windows stop errors the lot.
The card has been replaced aswell as the memory i bought too which come back today.

Any help greatly appreciated.

Thanks.
 

Nemesia

Respectable
Nov 6, 2019
2,479
472
1,890
91
A thread was just solved with someone who had a no signal while installing drivers. It was a bad HDMI cable. Try another cable in case it's just a cable issue.

Did you download and install the chipset drivers from AMD's website too? Not only the GPU drivers but the B450 chipset drivers.
 
May 21, 2020
6
0
10
0
A thread was just solved with someone who had a no signal while installing drivers. It was a bad HDMI cable. Try another cable in case it's just a cable issue.
I have tried different cables the problem seems to be the drivers will not fully install.
As the installation gets near 80% my system hangs and i get no signal error.

Edit on the chip set drivers i have tried installing this too too the same no signal error but when i install these drivers i get all sorts of windows stop errors which is a nightmare to get round without having to re install windows.
Rolling back to basic window drivers keeps windows on so it is definatley a display driver issue.
 
May 21, 2020
6
0
10
0
I’m having kinda the same problem but my gpu just shows a grey screen replaced everything but cpu and power supply
If you can get into safe mode.
Goto device manager, you display andf roll back the driver.
You should be able to run windows normally then all be it without the needed display driver.
 

ASK THE COMMUNITY

TRENDING THREADS