Question Ryzen 2600 > Ryzen 5600x Need help

Feb 27, 2021
3
0
10
0
Hello all,

I am currently updating my computer from a Ryzen 2600 to a 5600x

My system specs are,

-Msi x570 Gaming Edge Wifi
-OLOY 8GB 3200MHZ ram 4 x 8GB
-EVGA 2070 Super XC
-SANDISK 500GB SATA SSD (system drive OS: C)
-Samsung 1TB NVME SSD
-4TB HDD (Irrelevant to my issue)
-Corsair RM 850X
-Ryzen 5 2600

So to get to my issue, I purchased the motherboard in October of 2020. Which I do not believe that it had the bios update for Ryzen 5000 series. (unfortunately I did not check what bios version was installed before I flashed the bios) So to jump into it, I was able to buy a 5600x off of Newegg this week, excited I prepared for the upgrade. I downloaded the newest bios off of the MSI Global website. I put the bios onto a flash drive (Version 7C37v1D), and proceeded to install the bios. I installed the bios on my pc, successfully! Great now time to wait for the processor.

Fast forward two days...

Processor arrived.

Shutdown PC, remove AIO pump, install Ryzen 5600x!

Well that's where I have problems I cannot solve.

Once this processor was installed into my PC, for some odd reason it will not detect a single one of my drives. My sandisk boot drive, HDD, or the NVME. All that appears in the bios screen is a general boot order, showing the different types of devices you CAN boot from. No matter what I do I could not get the computer to detect the drives. So I backtracked, I removed the new processor, put back in my old 2600.

Restarted the PC, loaded the original bios settings, booted into bios. BAM. ..... all the drives show up.

exit bios boot to windows confused.

I repeated this process 2-3 times ... drives show up with ryzen 2600, do not show up with the 5600x

I changed the sata port settings in the bios to hotplugging enabled, booted with 5600x ... still no drives.

changed xmp enabled, disabled, changed a bunch of irrelevant settings. nothing...

I put the 2600 in booted, downloaded (7C37v1C) put it on a flash drive. installed it....

Now it boots into bios with no drives on the 5600x and boots to GPU/DISPLAY error (ez-debug led) on the 2600.

After some time I was able to get the 2600 booted. And ... here we are. Any suggestions?
 
Feb 27, 2021
3
0
10
0
Thermal compund - Coolermaster - mastergel pro

I did not reset the bios to its default state the first time I installed it, when it booted it asked me if I wanted to boot to setup or just load default settings. I booted to setup. set up my ram and what I thought was my boot drive.

The second time I booted, I did reset the bios to its default state, still made no difference.

Also, yes I did install that bios (7C37v1D ) and also went back to install the predecessor to that bios just in case.

Still no luck. ... I will put a video together tomorrow showing all this.
 

ASK THE COMMUNITY