Question Samsung 960 EVO is not detected by Windows/UEFI


Feb 16, 2015

I am writing this post because I am very desperate. I have checked a huge amount of similar posts on the Internet, but none of them seemed to help me.

My problem is that I want to replace my OS disk - OCZ Agility, running Windows 10 Home, with Samsung 970 EVO that I bought, but the 970 EVO is not being detected by Windows/Windows Installer/UEFI at all. So I can't install Windows on it.

Here's my specs:
  • Asus PRIME Z390-A;
  • Intel Core i7-9700K;
  • Corsair DDR4 2x8Gb;
  • OCZ Agility 3 128Gb;
  • Samsung 850 EVO 500Gb;
  • WDC 1Tb;
What I've tried so far:
  1. Updated the MB BIOS to the last version;
  2. Reset CMOS;
  3. Try different M2 slots on my MB (this particular MB has 2 slots: M.2_1 and M.2_2, one is for PCIe and SATA, the other is just for PCIe);
  4. Created 2 kinds of Windows bootable: bootable USB and burned ISO - none detect the 970 EVO while installing Windows;
  5. I also tried the original Windows USB that I bought in retail years ago - that one didn't detect the drive either;
  6. Messed around with CSM, Secure Boot, resetting Keys, boot options - trying all different variations of these, while having the 970 EVO drive the only drive plugged into the MB (that super long instructions list with disabling CSM and setting boot option to "Other OS" that I saw on other forums had no impact) - NONE of the options worked;
The thing is, I cant even get to that 970 EVO via diskpart, diskmgmt.msc or any third party software to initialize it or anything - so I can't access it via BIOS or Windows Installer. Unfortunately, I can't test the drive on other PCs, because I don't have any to test on.

I know that Windows Installer is supposed to have the drivers that support the NVMe drives, or the 970 EVO should contain the UEFI driver info, or in other case you can manually search for drivers during the installation process. With that said, I made a separate USB stick where I downloaded the Samsung NVMe driver, but the Installer didn't detect the driver on the USB.

In the UEFI settings I have an option: NVME Configuration, but when I select it, it says that "No NVME devices are detected".

Is there anything that can be done in this situation? The circumstances seem dire, and it looks like a complete waste of money on that 970 EVO.
Feb 15, 2019
Intel® Z390 Chipset :
1 x M.2 Socket 3, , with M key, type 2242/2260/2280/22110 storage devices support (PCIE 3.0 x 4 mode)
1 x M.2 Socket 3, with M key, type 2242/2260/2280 storage devices support (SATA & PCIE 3.0 x 4 mode)*5

*5 The M.2_1 socket shares bandwidth with SATA_2 port when using M.2 SATA devices. Adjust BIOS settings to use a SATA device.

This is your MOBO, if the M.2. IS SET TO sata, you will never see the NVMe!