[SOLVED] Sanity check before swapping memory and/or motherboard -- RAM configuration changes not taking effect.

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
Hey all, need a quick sanity check before I ditch this motherboard and RAM and buy new kit.
Currently:
  • Ryzen 7 2700X
  • MSI X470 Gaming Plus (up-to-date BIOS)
  • 16GB(2x8) DDR4 Corsair Vengeance LPX 3000MHz 15-17-17-35 (in the recommended slots)
So I have tried numerous things to adjust RAM speed through the BIOS to what it should be -- 3000Mhz -- and despite the steps I've taken, the speed remains at 2133Mhz as seen through Windows and CPU-Z. Really, the only thing I have yet to do is test a single stick on its own, but that doesn't necessarily solve my problem, just verifies an issue with the hardware.
  • I have disabled and enabled XMP profiles. When enabling profile 2 (2933Mhz), the computer goes into a reboot loop.
  • I have enabled XMP profile 1 without any effect.
  • I have manually adjusted the RAM speed to 3000MHz. I have turned off memory fast boot.
In trying to research the issue I have come across a few other cases where users are having similar issues with Ryzen and Corsair Vengeance memory, especially with these timings, which is why I think I'm going to buy new kit.

Any advice or last-ditch efforts would be appreciated.

edit: Also for some reason, I can't change any advanced DRAM configurations, i.e. timing, voltages, etc. It's all grayed out in the motherboard BIOS (even with "advanced"/"expert" mode turned on).
 
Set DRAM voltage to 1.35V,
Main timings to 15-17-17-17-35,
Leave sub timings on auto,
Command rate to 1T,
Set DRAM frequency to 2133mhz, test it,
Increase DRAM frequency and test again (2400mhz, 2600mhz,2800mhz,2933mhz).
If a test fails, then return to previous settings that worked.
 

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
Set DRAM voltage to 1.35V,
Main timings to 15-17-17-17-35,
Leave sub timings on auto,
Command rate to 1T,
Set DRAM frequency to 2133mhz, test it,
Increase DRAM frequency and test again (2400mhz, 2600mhz,2800mhz,2933mhz).
If a test fails, then return to previous settings that worked.
I can't change the values. That's what we have been talking about. The values are static, there's no way for me to go in and change the timing configuration, that's what I said in the OP.

edit: NVM, think I figured out how to change the values... changing now. Will report back
 

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
Now task manager reporting that hardware reserved memory is 8.1 GB.

Removed memory and resinserted, now task manager reporting reserved memory at 51.9MB.
 
Last edited:

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
Did you set DRAM voltage?

May want to experiment with "Memory Try it" setting.
Yes, I entered 1.35 but gray text continues to show the voltage at what it was before. So not sure if it's actually set.

I did attempt to use the Memory Try It! feature but experienced the same symptoms: memory speed is reported at 2133Mhz regardless of what I tried.
 

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
1.35 is next to the gray 1.24 or whatever the original voltage was. They're both displayed side-by-side, so not sure if it's similar to the frequency where I set it and it shows to what I set it to in BIOS, but in Windows it's reporting the original setting (i.e., you can see in BIOS that I set the frequency to 3000Mhz but says Current DRAM frequency is 2133Mhz)
 

azuma1

Distinguished
Jan 12, 2013
25
0
18,530
0
I went back in, reset the setting to default, set the voltage back to 1.350 V, pressed enter, saved and rebooted, went back into BIOS, and the gray setting changed.

Strange thing is I saved and rebooted every time I made a change, but it worked this time for some reason.

Everything looks good now. Thanks for walking through this with me.
 

ASK THE COMMUNITY

TRENDING THREADS