Screen dims itself randomly

Daniel Ilic

Reputable
Dec 29, 2014
48
0
4,530
0
I bought a new pc last week and i've noticed that from time to time my screen just dims itself randomly be it that i'm gaming or you surfing the net. I tried playing with monitor setting but that didnt work so i think its something with the gpu that i have. I also tried changing around the settings in nvidia panel but that didnt work. The only way to fix is if i reset the pc or if i unplug hdmi cable from the gpu. Drivers are all the newest ones.
PC components:
Ryzen 5 1600 running on stock speed's
GTX 1050 ti also on stock speeds
8gb hyperx predator 3000mhz
 
1.Try to reset in settings of monitor " Adjust the contrast and brightness on On-Screen Display. (The backlight of the LCD monitor has a fixed life span. When the screen becomes dark or begins to flicker, please contact your sales representative)."
2. Download its driver and install them http://www.driverscape.com/download/philips-220e-%2822inch-wide-lcd-monitor-220e1%29 (last download link, First one is AD)
3."I was instructed that ONE possible way to fix this dimmed desktop was to go on your NVIDIA Control Panel and under the Display menu -> Adjust desktop color and settings -> undot Other Applications control color settings to Use NVIDIA settings."
4.If you are using the traditional Windows desktop:
Touch and hold the start button to bring up the Apps screen and touch the Control Panel app.
Touch Hardware and Sound.
Touch Change Plan Settings.
Touch Change Advanced Power Settings.
In the advanced power options, touch the + next to Display to open the options.
Locate the setting for Enable Adaptive Brightness and set the appropriate options to Off.(touch means click or type control panel in search).
 

Daniel Ilic

Reputable
Dec 29, 2014
48
0
4,530
0
1. Tried completely reseting the monitor settings but with no luck.
2. Installed the drivers you sent me but still no luck.
3. Tried that also, i even played around with settings in the panel.
4. Adaptive Brightness was by the default turned off in the Ryzen balanced power plan
 
Oh , go to control panel, hardware, power settings, and from left tab click choose when to turn off, and check if its set to never,
If that didnt help, then go to power plan and set it to high perfomance (under Show additional power plans),it should be saying change plan settings and go to change Advanced ,check every tab for Turn off and etc that is set to never and 0 minutes,except processor power plan, and last 2 should be Display and Multimedia, under display there should be adaptive Brightness and set it to 0 minutes (Its setting for Never).

Well why didn't i remember this in First place.... If this doesn't help then im out of ideas.
 

Daniel Ilic

Reputable
Dec 29, 2014
48
0
4,530
0
It was already set to never, high performance didnt fix it either. In the advanced settings it was already set on off for adaptive brightness
 
Just checking, did you try on other monitor/TV? Or play with settings in nvidia control panel?
Last option is that your LCD is dying, which would be awkard... Take it to repair shop it could be simple resistor or capacitor cap.(In case that it happens on your second monitor/TV.)
 

Daniel Ilic

Reputable
Dec 29, 2014
48
0
4,530
0
It just happens out of blue it doesnt matter if i'm playing games or i'm watching movies, videos, listening to music or doing something in windows. It just happens so it would take a lot of time to have it happen and then cut out the video.
 

ibjeepr

Distinguished
Oct 11, 2012
632
0
19,010
14
I did a new system build with a 1080 Ti and I was getting a weird dimming / flicker where the monitor would seem to get darker/ subtle color shift every few seconds only noticeable on bright spots on the screen. I did the following and fixed it:

1) Go to Control Panel > Hardware and Sound > Power Options, then click on "Change plan settings" next to your active power plan. Scroll down to Display, then under Enable adaptive brightness, switch it off for both the battery and plugged in modes.

2) https://www.youtube.com/watch?v=HDKABeVisIY. I did everything it says.

If just one thing or another would have done it I can't say because I did it all.
 

Daniel Ilic

Reputable
Dec 29, 2014
48
0
4,530
0
Sorry for not answering for a long time i had some health issues... The problem was aparently that whenever i minimized games while they ran in Fullscreen mode that dimming happened so i switched it to windowed fullscreen which somehow fixed it. Any ideas why that could be causing it to dim?
Adaptive brightness was already turned off.
 

ASK THE COMMUNITY