Question Screen went black while not doing anything intensive GPU usage

Aug 10, 2020
2
0
10
0
So i started my PC, left it to go outside for around 15-30 minutes.
When i got back, everything is still normal. So i decided to play some games.
I started GTA San Andreas and everything was going okay for around 5-10 minutes until everything went black. (black cause the signal from GPU was lost)
My PC was still running, as the game sounds are still playing, and when i try to control the game with my keyboard, it still does the intended stuff interpreting from the sound, i thought it was just a random black screen so i decided to wait it out a bit, but it never came back.
So i decided to restart the PC, if that fixes it, it didn't work.
I also unplugged and re-plugged the cables to my monitor, it also didn't work.
I did some further investigation, i plugged my monitor to my motherboard/built in graphics (which i am using to make this post)
and it worked, i tried checking event viewer and stuff but i can't find anything useful. (or haven't found, as of writing this post)
I checked inside my PC, the GPU as not heated whatsoever and its fan isn't spinning, i'm not sure if this is because i have not connected it to a monitor on startup.

COMPUTER SPECS:
Core i7-8700
GTX 1050ti (4gb)
16 GB of DDR4 ram
256 GB of SSD,
1TB of HDD.
 
Aug 10, 2020
2
0
10
0
I'll try that as soon as i get my hands on some screwdrivers.
I kept fiddling with it, and it randomly started working when i changed the initial boot on BIOS to PCIe 2, but as soon as i restarted my PC again it stopped working.

So i can confirm that my graphics card isn't dead, is there anything i can do without reseating the GPU?
 

ASK THE COMMUNITY