[SOLVED] Security Permissions messed up for some of my folders in Windows 7

Technologify

Reputable
Jul 3, 2016
292
0
4,860
31
(im posting this in windows 10 because windows 7 and 10 security tabs are basically the same)

My issue is that some of my folders and files are now Denied permission under [Everyone] user group, so I need to go through 4 tabs and 10 buttons to change permission to full control to finally open my files. This only happened after stupid windows disk check, which I turned off now, and it only happened to some of my files. How would I revert permission or give [Everyone] Full Control without having to click like 10 buttons for each folder?

Picture View: https://i.imgur.com/kTE4PP2.png
 

Ralston18

Titan
Moderator
Inherited Permissions:

https://www.tenforums.com/tutorials/88305-enable-disable-inherited-permissions-objects-windows.html

https://winaero.com/blog/enable-disable-inherited-permissions-windows-10/

Just be sure that you understand the folder/file structure: who has what rights and permissions to any given file or folder.

Back everything up beforehand.

Do not try any global settings or broad reconfigurations.

Focus on the smallest problem Folder and files first. Get that sorted out and fixed.

Then use what you learn to go forward thereafter.
 

Ralston18

Titan
Moderator
Inherited Permissions:

https://www.tenforums.com/tutorials/88305-enable-disable-inherited-permissions-objects-windows.html

https://winaero.com/blog/enable-disable-inherited-permissions-windows-10/

Just be sure that you understand the folder/file structure: who has what rights and permissions to any given file or folder.

Back everything up beforehand.

Do not try any global settings or broad reconfigurations.

Focus on the smallest problem Folder and files first. Get that sorted out and fixed.

Then use what you learn to go forward thereafter.
 

Technologify

Reputable
Jul 3, 2016
292
0
4,860
31
Inherited Permissions:

https://www.tenforums.com/tutorials/88305-enable-disable-inherited-permissions-objects-windows.html

https://winaero.com/blog/enable-disable-inherited-permissions-windows-10/

Just be sure that you understand the folder/file structure: who has what rights and permissions to any given file or folder.

Back everything up beforehand.

Do not try any global settings or broad reconfigurations.

Focus on the smallest problem Folder and files first. Get that sorted out and fixed.

Then use what you learn to go forward thereafter.
I have to do this folder by folder and its exactly what I said I dont want to do. There's a good amount of them (100+)

Hey I have fixed the issue by doing this to whole C: drive and giving Full Control to all subfolders. For some reason this didn't work the 3 times I tried yesterday, I got [Access Denied] error for all folders but now it works.
 
Last edited:

Ralston18

Titan
Moderator
Okay. That is progress.

Your entire system may be wide open so do not leave that situation un-attended.

Now just go back and reset/reconfigure the security and permissions for those folders that you most want to protect.

Prioritize.

Work from desired "High" protection/access levels down to "Lower" protection/access levels.
 

ASK THE COMMUNITY