• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question SFTP connection issues.

May 1, 2020
3
0
10
0
I'm having some unexplained SFTP connection issues which I hope someone might help to resolve.

With my previous ISP an SFTP server I have been connecting to for many years suddenly stopped accepting my connections. I had my home security cameras setup to upload recordings to the server and on an occasion tons of footage was uploaded during a day. Just after this the problems begun - but I can't be sure that the event is directly related.

Here is what I have done to troubleshoot:

1. Contacted the host - who confirmed I'm not blocked

2. Tried connecting to the server from another device on my network (PC and MAC) - also unable to connect

3. Tried disabling all firewalls and anti-virus - also unable to connect

4. Tried tetthering to my phone's data plan and I was able to connect!


This all led me to conclude that I must be blocked at the ISP level. Since I was due to leave the previous ISP I guessed that all would be resolved when I changed ISPs. My account and service was activated this week and lo and behold I have the same issue persists.

I know that:


1. My device isn't blocked (connection via phone works)

2. The ISP isn't blocking me : (2 ISPs same result)

3. The host is not blocking me (phone connection works)

4. FTP on port 21 works!

5. My FTP software is correctly configured (I also tried another FTP client)


It seems that I am being blocked at a higher infrastructure type level - if that is possible?

the error message is:

Error: FATAL ERROR: Network error: Connection timed out
Error: Could not connect to server


Other FTP connections work fine and I have tried setting the timeout to 0 to avoid connection issues! This problem is driving me crazy and I've run out of ideas. Any suggestions?


Thanks!
 
May 1, 2020
3
0
10
0
I have tried a domain name and the IP it resolves to. When I ping both I get a response and it looks good. The server also requested I do a trace route which was successful. It really is a mystery.
 

ASK THE COMMUNITY

TRENDING THREADS