Sharing Files on LAN - windows bug or something else?

Hello guys! I'll try to make this as descriptive as possible.

Basically, few months ago I ran into an issue: everybody in my home started getting errors when trying to access the files I've shared on the network. There is my father's desktop and my sister's laptop. I tried resharing those folders and I ran into an error. That's what I'm doing, and it works perfectly among the other two computers:

I also cannot access files shared by other computers, it says it cannot find the path specified. However, the other two computers may exchange files without any problems at all.

I've been to a LAN party last month, and I've tried sharing some files there - thought maybe it was the router. However, even when it was a different router, the problem still occurred. I found a temporary solution: FileZilla software. However, windows explorer is so much better for handling files, and doesn't require to download them to open them (like watching a 20 GB movie). I'd like to have this sorted, because my sister uses my computer as an external harddrive - installs games on it, etc, - her laptop has only 20 GB hard drive. It worked like a charm until that one day. I've got no idea what's up, maybe I disabled a service which handles that?

List of disabled services:

I would be grateful if anybody could solve it.

Thanks dude, you have no idea how much you helped me with the first link. Basically, upnphost service was disabled (I just disabled services which I think I didn't need >.<), and in my network Local Area Network adapter properties I added Client for Microsoft Networks, QoS Packet Scheduler and File and Printer sharing for Microsoft Networks, and it works! Thanks again!