Question (SLI) 2x RTX3090Ti + NVLINK Problem

Sep 13, 2022
5
0
10
0
Hello everyone. Recently I wanted to improve the quality of my work and try SLI. I have one Gainward RTX 3090TI card, bought a second card and plugged it into the slot. I purchased NVLink Ampere (3 slot) and connected them together. I turned on SLI in Nvidia options, as people describe it on the internet. SLI turns on without a problem, both cards are visible. The problem is that there is no difference between one and two cards. When I turn SLI off, I have the same performance as when SLI is turned on. The main card works at 99%, heats up to 80 degrees, and the second one works smoothly, effortlessly with a temperature of 50 degrees. As if the second card was not working at full capacity. I did a test in 3Dmark and the result is the same for one / two cards.
Maybe I need to add something extra? I have the latest Nvidia drivers. I work in Davinci Resolve Studio and the rendering is also the same for one / two cards. The program sees 2 cards, even has NVlink assigned to it, but the video rendering is the same with one or two cards. What did I do wrong?

My specs:

Windows 11
Gigabyte Aorus TRX40 PRO WIFI
256GB RAM Kingston (3600mhz)
2x GAINWARD RTX 3090Ti
AMD Threadripper 3960x
Aio Cooler Master ML360 (for threadripper)
Corsair 1600W
 
Last edited:
So, the article you posted states about the same as the thread I posted, with regards to expected performance.

Do you have newer info that says you should see a performance benefit when using NVLink? In fact, it looks like you'll get the best results with NVLink and SLI off.
 
Sep 13, 2022
5
0
10
0
I have no information. I am puzzled by the fact that the second card is blank and works for 30%. In this aticule, you can see that both gpu have the same ranks, so they are probably paring at the same level. For me, the first card works at 80 degrees Celsius, and the second one at 50 degrees or even less. It is the same in games. R2D2 on the highest settings spins to 90 degrees Celsius, and the other card does not want to work (50-60 degrees). As if she had some kind of blockage. I swapped cards with slots and the same thing again.
 

Karadjgne

Titan
Ambassador
Davinci added support for nvlink in version 17.0. Prior to that, there was No support because the bandwidth of nvlink/sli was too low to be effective.

So what you have is software that'll support nvlink, but honestly sees No gains from it, it just doesn't complain about whether it's active or not like it did in the past.

You can try using mgpu without the nvlink but must turn Off 'Hardware-accelerated GPU scheduling' in Win11.
 
Firstly, games are not SLI compatible anymore,very very few games still works in SLI, search which of them are, 2nd look very well in the da vinci menu, maybe you need to activate something or change a setting to be able to use them both, or maybe they gave up on SLI support.
 

Karadjgne

Titan
Ambassador
Sli support is effectively dead, nvidia isn't refurbing it, and starting with windows 10 and DX12, it's no longer SLI native based, it's mgpu based. Coupled with nvidia total lack of hardware capable of sli except the 3090/ti I'm not exactly sure why DaVinci v17 decided to include sli compatibility.

It's like showing upto the bar 1½ minutes before last-call...
 
Sep 13, 2022
5
0
10
0
@Karadjgne I turned "off" option "Hardware-accelerated GPU scheduling: and second card started to work perfectly. All fans in graphics cards are working. Now I can playback as I wish. It's true that it's only 17 fps, but that's enough for me (added sharpen, reduce noise, massive color grading and other plugins -that's why so little fps). Now the movie rendering half the time. Previously, 10 minutes video was rendering around 70 minutes, now rendering was only 33 minutes. I can't tell if the second card works on full performance, but I like it. In Davinci Resolve it also need to unmark "auto" in "preferences" next to the option "CUDA" and unmark "auto" on the graphics cards. NVLINK is displayed next to the cards.

Thank you!
 
Last edited:

ASK THE COMMUNITY