Question [Solved] 3080ti getting 15fps on some games

Nov 9, 2021
3
0
10
0
Uninstalling Citrix Receiver fix the issue like magic.




Just finished building this PC last week. Weirdly I'm getting extremely low FPS on some games. Yet some other games run just fine. Here's a list of some games I tested and the results:

New world (steam): 15fps as soon as game launches, even in loading page only getting 15fps. Changing graphic settings doesn't help at all. GPU Usage at 20%-40%.
Cyberpunk 2077 (steam): 80fps on ultra graphics, 120fps on high graphics. 90% GPU Usage. Seems reasonable to me. Which makes me think it's not a hardware issue.
Metro Exodus Enhanced Edition (Epic Games): 160fps on ultra settings. 80% GPU Usage.
Witcher 3 (steam): 10fps, GPU usage 18%
World of Warcraft: 60fps on high settings
League of Legends: 240fps on ultra settings.

Anyone has any suggestions to fix the issue? Looks to me GPU is not running on appropriate usage level yet I can't figure out why. Any help would be appreciated.

My build:

CPU: Ryzen 7 5800x Vermeer 3.8Ghz 8-Core AM4
Graphic Card: NVIDIA - GeForce RTX 3080 Ti 12GB GDDR6X PCI Express 4.0 Graphics Card - Titanium and Black
Motherboard: X570 TUF Gaming Plus (WIFI) AMD AM4 ATX Motherboard
Memory: G. Skill Trident Z Neo Series RGB 32GB (2x16GB) DDR4-3600 CL16 Dual Channel Memory
SSD: Samsung 980 SSD 1TB M.2 NVMe Interface PCIe 3.0x4
Power supply: Seasonic FOCUS GX-850 850W 80+ Gold
OS: Windows 11 (problem exists in windows 10 before I upgraded to 11)
Current driver version: 496.49. I reinstalled driver twice

Userbenchmark: https://www.userbenchmark.com/UserRun/47759029
 
Last edited:

danyuzunov

Prominent
Jul 27, 2020
56
2
535
0
Just finished building this PC last week. Weirdly I'm getting extremely low FPS on some games. Yet some other games run just fine. Here's a list of some games I tested and the results:

New world (steam): 15fps as soon as game launches, even in loading page only getting 15fps. Changing graphic settings doesn't help at all. GPU Usage at 20%-40%.
Cyberpunk 2077 (steam): 80fps on ultra graphics, 120fps on high graphics. 90% GPU Usage. Seems reasonable to me. Which makes me think it's not a hardware issue.
Metro Exodus Enhanced Edition (Epic Games): 160fps on ultra settings. 80% GPU Usage.
Witcher 3 (steam): 10fps, GPU usage 18%
World of Warcraft: 60fps on high settings
League of Legends: 240fps on ultra settings.

Anyone has any suggestions to fix the issue? Looks to me GPU is not running on appropriate usage level yet I can't figure out why. Any help would be appreciated.

My build:

CPU: Ryzen 7 5800x Vermeer 3.8Ghz 8-Core AM4
Graphic Card: NVIDIA - GeForce RTX 3080 Ti 12GB GDDR6X PCI Express 4.0 Graphics Card - Titanium and Black
Motherboard: X570 TUF Gaming Plus (WIFI) AMD AM4 ATX Motherboard
Memory: G. Skill Trident Z Neo Series RGB 32GB (2x16GB) DDR4-3600 CL16 Dual Channel Memory
SSD: Samsung 980 SSD 1TB M.2 NVMe Interface PCIe 3.0x4
Power supply: Seasonic FOCUS GX-850 850W 80+ Gold
OS: Windows 11 (problem exists in windows 10 before I upgraded to 11)
Current driver version: 496.49. I reinstalled driver twice

Userbenchmark: https://www.userbenchmark.com/UserRun/47759029
No idea
 

danyuzunov

Prominent
Jul 27, 2020
56
2
535
0
Just finished building this PC last week. Weirdly I'm getting extremely low FPS on some games. Yet some other games run just fine. Here's a list of some games I tested and the results:

New world (steam): 15fps as soon as game launches, even in loading page only getting 15fps. Changing graphic settings doesn't help at all. GPU Usage at 20%-40%.
Cyberpunk 2077 (steam): 80fps on ultra graphics, 120fps on high graphics. 90% GPU Usage. Seems reasonable to me. Which makes me think it's not a hardware issue.
Metro Exodus Enhanced Edition (Epic Games): 160fps on ultra settings. 80% GPU Usage.
Witcher 3 (steam): 10fps, GPU usage 18%
World of Warcraft: 60fps on high settings
League of Legends: 240fps on ultra settings.

Anyone has any suggestions to fix the issue? Looks to me GPU is not running on appropriate usage level yet I can't figure out why. Any help would be appreciated.

My build:

CPU: Ryzen 7 5800x Vermeer 3.8Ghz 8-Core AM4
Graphic Card: NVIDIA - GeForce RTX 3080 Ti 12GB GDDR6X PCI Express 4.0 Graphics Card - Titanium and Black
Motherboard: X570 TUF Gaming Plus (WIFI) AMD AM4 ATX Motherboard
Memory: G. Skill Trident Z Neo Series RGB 32GB (2x16GB) DDR4-3600 CL16 Dual Channel Memory
SSD: Samsung 980 SSD 1TB M.2 NVMe Interface PCIe 3.0x4
Power supply: Seasonic FOCUS GX-850 850W 80+ Gold
OS: Windows 11 (problem exists in windows 10 before I upgraded to 11)
Current driver version: 496.49. I reinstalled driver twice

Userbenchmark: https://www.userbenchmark.com/UserRun/47759029
Can you say what chassis and cooler ya rockin?
 
Nov 9, 2021
3
0
10
0
Can you say what chassis and cooler ya rockin?
I'm using Lian Li Lancool II Tempered Glass eATX Mesh Midtower Case. Cooling is Deep Cool CASTLE 240EX 240mm RGB Water Cooling. GPU temp seems ok to me. 45C while running at 90% usage when playing Cyberpunk on ultra graphics.
 

danyuzunov

Prominent
Jul 27, 2020
56
2
535
0
I'm using Lian Li Lancool II Tempered Glass eATX Mesh Midtower Case. Cooling is Deep Cool CASTLE 240EX 240mm RGB Water Cooling. GPU temp seems ok to me. 45C while running at 90% usage when playing Cyberpunk on ultra graphics.
Try rebuilding, if it doesn't help install fresh windows 10 and test it with the problematic games before downloading any other programs! Just the needed drivers and the games.
 
Nov 9, 2021
3
0
10
0
Try rebuilding, if it doesn't help install fresh windows 10 and test it with the problematic games before downloading any other programs! Just the needed drivers and the games.
Thanks. Found the fix. Uninstalling Citrix Receiver did the trick. Thanks to a random article in New World's forum.
 

ASK THE COMMUNITY