[SOLVED] Black screen randomly throughout the day [SOLVED]

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1
Hey so my 2 monitors go black several times a day randomly this has been happening for a while now any help is much appreciated.

Event viewer error from System: Display driver nvlddmkm stopped responding and has successfully recovered.
Event viewer error from Application: The Desktop Window Manager process has exited. (Process exit code: 0xe0464645, Restart count: 1, Primary display device ID: NVIDIA GeForce GTX 970)

SPECS:
i7 4790k
gtx 970
16gb ram
MSI h81m-e34
gl 2450 x2
windows 10 pro
1hdmi 1vga gonna be 2hdmi in a few days
 

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1
[ANSWER][ANSWER][ANSWER][ANSWER][ANSWER][ANSWER]



Ok so pretty sure i have the issue sorted now as it has not happened in 2 days now and usually it is a few times a day.

What i did was put the core and memory clocks of my gpu using MSI afterburner down to around -60 and now the issue has not happened again.
Before doing that i did add another fan to my case to lower temps as they were awfully high it lowered temps by about 20% even though it never sorted my issue it was great and i definately needed another fan

If anybody knows why this sorted it please do let me know
 

smashjohn

Reputable
Aug 14, 2017
574
12
5,365
136
I had this issue with a 980 for a while. Here's everything i learned that can cause it in no particular order:

logitech webcam conflict (unplug logitech webcam)
using y adapters instead of pci-e power cables on video card (just don't do this, not enough wattage)
using y adapters instead of pci-e power cables on motherboard pci aux power (just don't do this, not enough wattage)
running evga precision (uninstall it)
using your gpu for phys-x (switch to cpu for testing)
driver corruption (full uninstall, full reinstall of drivers)
Nvidia Experience (uninstall it)
manufacturer settings (go into nvidia control panel and select debug mode under tools or help. This sets the card to run nvidia reference settings)
UEFI incompatibility issue (flash motherboard bios)
overheating (using manufacturer software to set all fans to 100% for testing)
logmein/gotomypc conflict (uninstall for testing)

that's all i can remember right now. good luck!
 

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1


Thanks for getting back to me.

I dont have a webcam at all.
pretty sure i am not using y adapters.
no evga precision installed.
No logmein or gotomypc installed on this pc.
fully uninstalled GPU and motherboard drivers and reinstalled, still happened.

I have now set the phys-x to use the cpu and will see if it still happens or not.
Have debug mode on right now aswell.
if it does still happen i will uninstall Experience and see if it happens.
My CPU i7 4790k at idle with 4 chrome tabs open steam skype and discord is at 50C is that normal with only 10% usage (on high performance power option)?
 

smashjohn

Reputable
Aug 14, 2017
574
12
5,365
136
It's crazy how many threads there are about this issue with no consistency.

Something that helped me was using EVGA Precision to log everything about my card. The logging continued past my black screen. This didn't tell me what was wrong, but it did eliminate a lot of possibilities. I was able to confirm that gpu power, fan speed, and temps were not my issue. This also let me test maxing fan speeds and underclocking before I learned that it can also be a theoretical contributor to problems and uninstalled.
 

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1


yup went through tons of posts before deciding to create my own haha

I'm not sure if AMD drivers conflict and cause issues with Nvidia drivers and gpus but i used amds tool to uninstall all AMD things (it uninstalled alot) and have been testing since with no issues, will post back if it happens again or not
 

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1
right so now i am barely getting any black screens compared to before but still damn annoying is there a way to use bluescreenviewer on windows 10 to see if any programmes/drivers are conflicting or any other programme which can do this for me?
 

Nickz_16

Reputable
Dec 25, 2014
84
0
4,640
1
[ANSWER][ANSWER][ANSWER][ANSWER][ANSWER][ANSWER]



Ok so pretty sure i have the issue sorted now as it has not happened in 2 days now and usually it is a few times a day.

What i did was put the core and memory clocks of my gpu using MSI afterburner down to around -60 and now the issue has not happened again.
Before doing that i did add another fan to my case to lower temps as they were awfully high it lowered temps by about 20% even though it never sorted my issue it was great and i definately needed another fan

If anybody knows why this sorted it please do let me know
 

ASK THE COMMUNITY

TRENDING THREADS