Question [SOLVED]Please help- Operating System Not Found

Jan 25, 2021
4
0
10
0
So I recently did a new build and got a new skhynix SSD for a fresh windows 10. Ever since I think the first time I shut it down- whenever I boot I get the "operating system not found, try disconnecting any drives that don't have an OS installed" well that works which is great, except for the fact that I cannot boot with my other drives connected. Now here’s the complicated bit- I’ve tried everything I can think of
-updated bios
-reset CMOS
-Reinstalled windows using internet option just in case something was wrong with my boot media
-boot order in bios is correct (however there is no separate windows boot manager option for the drive, just the drive)
-fast boot is off
-tried boot override
-drives do not show up in disk management

If anyone knows what else I could do I’m all ears because I thought I was pretty proficient at this stuff but I’m at a total loss and nothing I can find online seems to be helpful
 
Jan 25, 2021
4
0
10
0
when you install windows. make sure all other drive a disconnected

full system spec?
All other drives were disconnected both times windows was installed

spec:
i5-9400F
Gigabyte B365M DS3H (running latest non beta bios)
8gb x 2 Gskill ripjaws V
Evga gtx 960 ssc
Evga 500B psu
Skhynix s31 500gb (boot drive)
Other drives I’m trying to use:
A 500gb adata ssd
500gb WD hdd (both worked fine in my previous pc)
 
Jan 25, 2021
4
0
10
0
System is installed in UEFI mode.

If legacy mode is enabled, then better disable it. So both modes being enabled doesn't cause confusion.
Set CSM to disabled in BIOS.
bios was set to UEFI and not legacy so I’m not sure why that was the problem but disabling CSM worked!!! Thank you so much. This has been the bane of my existence for the past several days. You’ve saved me so much trouble I really appreciate it
 

ASK THE COMMUNITY