Question (SOMEONE PLEASE HELP ME) Why do I drop to 13 frames every 40 seconds when gaming?

Nov 29, 2019
3
0
10
0
I need serious help lol. Most games I play would drop from a stable 60 frames to 13 frames unexpectedly. I guess you can say that I play on a "budget" gaming laptop. The frame drop would usually last for 10 seconds and then goes back to a normal 60 frames.

Gpu: MX150
Cpu: Core i5-8250U CPU @ 1.60GHz, 1800 Mhz, 4 Core(s)

Here is an example of what I experince when the drops start happening coming from the app FPS monitor (I'm only playing roblox as an example):

I'm no tech guy but I know these numbers aren't good for a cpu? SOMEONE PLEASE HELP ME.
 
Last edited:
Feb 26, 2019
18
0
10
1
I dont necessarily know the answer but more information would be nice. What is your ram like and your power supply unit. I believe even your operating system could factor into this. Also does your problem always happen or did it recently just start?
 
Nov 29, 2019
3
0
10
0
I dont necessarily know the answer but more information would be nice. What is your ram like and your power supply unit. I believe even your operating system could factor into this. Also does your problem always happen or did it recently just start?
i don't really know much about computers but I know that I have 8 gb of ram. It has also been happening for over 5 months now (I got my laptop a year ago)
 

maxamillionfeettall

Distinguished
Mar 27, 2011
297
37
19,040
63
The cpu is hard bottlenecking the gpu, since it's a laptop, it's doubtful that there is an upgrade option.
For some reason your cpu clockspeed is only 399mhz, it should be considerably higher, change you power settings to high performance, there may be a need for bios adjustments, but I can't say.

You can try to cap your fps either in the options menu or through a third part program like rivatuner.
Make sure there are no other tasks happening in the background.
 
Nov 29, 2019
3
0
10
0
The cpu is hard bottlenecking the gpu, since it's a laptop, it's doubtful that there is an upgrade option.
For some reason your cpu clockspeed is only 399mhz, it should be considerably higher, change you power settings to high performance, there may be a need for bios adjustments, but I can't say.

You can try to cap your fps either in the options menu or through a third part program like rivatuner.
Make sure there are no other tasks happening in the background.
Usually it would be 3.4k Mhz when its not lagging and the voltage would be a lot higher too
 

maxamillionfeettall

Distinguished
Mar 27, 2011
297
37
19,040
63
Usually it would be 3.4k Mhz when its not lagging
Alright, seems like a thermal throttle despite the temps not being that high, might be spiking and then dropping rapidly thereafter.
Google shows issues with either being plugged in/external battery, or the cpu fan not properly working. First set your powerplan to high performance and maybe set your cpu fan speed to 100% all the time, if that doesn't work, look up how to get into the bios and disable cool and quiet or whatever that feature is.
 

ASK THE COMMUNITY

TRENDING THREADS