Question Something is destroying my EFI and system partition

Aug 18, 2019
I've got very difficult problem. First of all you need to know my volumes configuration, cause I want to describe the problem with vol letters:

Disk 0 (SSD GPT 240 GB):
  • C: System (NTFS/223 GB)
  • F: Restricted (NTFS/579 MB)
  • G: (No label) (FAT32/100 MB) (EFI partition, letter assigned to fix it by bcdboot)
Disk 1 (HDD 320 GB):
- D: Files (NTFS/298 GB)

Okay. So last time I downloaded Car Mechanic Simulator 2018. Everything was working fine, but when I turned on my computer the day after, Windows surprised me with Automatic Repair Tool screen. CHKDSK didn't work so I launched mini XP and noticed that C partition went RAW. I formatted whole disk, cause i haven't got anything important on it, and deleted every single file of that game (I thought that was the problem) and installed pure original Windows 10 Edu (my school is supported by Microsoft so students received Windows 10 Edu serials)

After installation I also installed Malwarebytes. Scanned every single partition, they were clear, but then mbam notified me about blocked domain because of trojan on it (this is my ISP Provider's domain, yes, I emailed them and the case is forwarded to administrators). I decided to play NFS on Origin.

And when I was just playing, the game froze, I wasn't able to do anything (ctrl alt del, alt f4, ctrl alt esc, alt tab) nothing worked, then my screen went black only with cursor on it, then the crit error windows showed up, telling me that system couldn't open ctrl alt del window, and i should click esc or restart computer. So i restarted it and Windows loading screen froze. I went again to the mini XP and the situation with RAW filesystem repeated. I found solution when it happens for the first time (without formatting the drive):

I'm recovering whole C: to the image file on D: with DiskGenius in the mini XP. Then i'm formatting C: and restoring the image to it, so filesystem question is solved. Then I'm formatting G: (EFI partition) by assigning letter to it and format to FAT32. Later I'm copying EFI files from Windows Sources to G: and using bcdboot. Finally i'm using chkdsk to check if it will go, and it works. Windows boots by UEFI, everything's fine.

But this situation is being repeated almost everyday, not every restart, just randomly when I'm playing something or just after my sleeptime. Everytime I'm using my earlier solution, but I'm getting rid of this. I also thought this is something about RAM but they passed memtest (by the HBCD) so I don't think so.

What should I do? I will be very greatful if someone would tell me what's going on.

EDIT: I forgot. After installation I created two recovery points, but when the situation happened they disappeared, I checked if bootrec sees my installation but it did.