[SOLVED] Sony Vaio laptop says "No battery installed" ?

Chris N

Distinguished
Mar 24, 2014
28
1
18,545
2
I am servicing a Sony Vaio Laptop (C10FK4MA) running Win 10 64-bit for a friend. It seems to be working fine except that it says "No battery Installed".

1- I have removed the battery and cleaned the contacts.
2- I have installed all the latest drivers and bios from the Vaio update app.
3- I have unplugged and removed the battery and discharged the computer with the power button.
4- I have launched Windows battery diagniostics but it cant help with the error, "no battery inserted". Sony Vaio battery care can't help either.

However, the problem persists. Of course it just may be the battery is bad. I don't have a spare to check. If that was the case., I would have expected a warning, "Battery not charging". Is there anything else I can try? Your advice would be appreciated?

Kind regards
Chris
 

Chris N

Distinguished
Mar 24, 2014
28
1
18,545
2
Thank you for your reply. Yes that makes sense. Unfortunately, I don't have access to another battery or laptop. Maybe a local shop would be willing to allow me to test one.

Kind regards
Chris
 
Thank you for your reply. Yes that makes sense. Unfortunately, I don't have access to another battery or laptop. Maybe a local shop would be willing to allow me to test one.
Yes you should ask a shop if they still have that laptop model.

Or if you know a group of computer enthousiasts in your area, you could ask for help, maybe someone can stop by with his/her laptop for a quick test.
 

ASK THE COMMUNITY

TRENDING THREADS