Sound not working on Custom PC?

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0
I just built my PC.
my mobo is a b150m-ds3h
my gpu is gtx 980
*I have only sought out drivers for my gpu and not mobo because computer does not have dvd drive so I did not bother*
I am running a BENQ Gaming 144hz monitor, with a headphone jack on the side.
That headphone jack does not work.
Under the windows 10 sound setting the only thing running was Digital Audio S/PDIF
Which doesnt seem to have audio.
I need audio (lol)
I also want it to run through monitor because it has a headphone jack and onboard speakers.
I am relatively new to computers so need basic assistance.
 

yyk71200

Distinguished
Mar 10, 2010
877
0
19,160
68
Download all needed drivers from motherboard builder (Gigabyte if I understand correctly) website including audio, chipset, etc. You can see all missing drivers in control panel --> device manager
 

DSzymborski

Glorious
Moderator


Yeah, you need to install all your motherboard drivers - it's literally the first thing you should do when you're in Windows on a new build. If there's still a problem after that, let us know; it's hard to diagnose a possible problem until all the necessary steps are taken!
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


All done. The rear port works, however not the front port or the monitor port.
 

yyk71200

Distinguished
Mar 10, 2010
877
0
19,160
68


1. Did you plug all front panel wires inside the case into appropriate pins on the motherboard (maybe a little confusing for the first time builder)?
2. If yes, open your sound controls (likely to be Realtek audio manager or similarly named if your audio is from Realtek, or something similar if some other audio chipset). Check if front audio ports even appear in configuration options there.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


Im assuming I screwed the plugging in up, is there a way to tell what is the best choice?
 

yyk71200

Distinguished
Mar 10, 2010
877
0
19,160
68
Check your board manual. It should say what pins on the motherboard are for front audio ports. Take the corresponding wires of your case that connect your audio ports and plug them in. There may be separate wires for audio out and microphone ports. Again, consult your motherboard's manual which wire should go where.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0

I do not have my manual, and cannot fnd it online.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0

I do not have my manual, and cannot fnd it online.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


Thankyou, I still dont have all the connectors I need though.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


It seems to have a chunk of wires that plug into the mobo internal ports. It also does not have enough to plug into everything.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


That is very helpful, except now nothing is connected to the speaker pin, whch does the audio port on the front
Also i have 2 power LED's? One has 2 pins one has 3, I matched the power Leds up with the two pin one
Also the 2 pins that say F_panel are not connected
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


NVM I am dumb. Howver my audio is not working period now. F audio is connected and I am getting audio in the back port, but it has a weird echo.
 

grrsona

Honorable
Feb 13, 2014
339
0
10,780
0


Okay got it!
2 last things: the front port does not fullly accept my headphone, it only fits partially in.
also my computer monitor has a headphone jack how do I enable it?
I am using DVI, do I need to plug in hDMI? How can I have sound and DVI?
 

yyk71200

Distinguished
Mar 10, 2010
877
0
19,160
68
Do you have line in plugged in like microphone? Click on line in or microphone in Realtec Audio Manager and make sure that playback volume (only for microphone or line in, not for actual headphones) is set to 0.
 

yyk71200

Distinguished
Mar 10, 2010
877
0
19,160
68


It should accept. You may have to use a little bit of force. And yes, you should use HDMI or Display Port if you want to use audio from your monitor. Make sure you choose this playback device afterwards.
 

ASK THE COMMUNITY