Question SSD failed and inaccessible

Jan 12, 2023
Hello, I recently had an SSD cause me all sorts of issues. The SSD was also my boot drive, with Windows installed on it. The other day when I went to boot my computer, it just hung on the ASUS splash screen stating "Press F2 or DEL to access the BIOS", but doing so did nothing. I eventually figured out that it was the SSD causing the problem, and when it was unplugged, I could access the BIOS by pressing F2 or DEL.

Since the problematic SSD was my boot drive, I reinstalled Windows on another drive and my computer was working again. However, there is some valuable data on that SSD that I would like to recover. I put it in an enclosure to see if I could access it, but when I try to, I get the error "The parameter is incorrect". If I attempt to open Disk Management with the SSD plugged in, it will just get stuck "Connecting to Virtual Disk Service", but will work without issue the moment the SSD is unplugged.

The only way I have been able to actually get Windows to recognize that the SSD exists is by going into command line and running "list disk" from diskpart. If I try to run "list disk" with the SSD plugged in, it will not complete. But if I run "list disk" and then unplug the SSD, it will show all of my drives, including the problematic SSD, as seen below.

The pins are all clean, and I have tried different cables, different slots on the mobo, different usb ports with the enclosure, and nothing has worked. Has anyone seen an issue like this before who may have some advice? Like I said, there is data on it that I would like to recover, so any and all help is very much appreciated. Thank you.