Question SSD not detected until I disconnect HDD?

Jan 31, 2019
4
0
10
0
So sometimes my computer will suddenly go black and say NO OPERATING SYSTEM DETECTED

when this happens I turn the computer off, unplug the HDD (os is on ssd), turn on the computer, sometimes it says no hard drive detected and reboots by itself and the computer will start and find windows.

then i turn off the pc, plug in the hdd again and turn on my pc and everything works.

Hours or a day later it suddenly does it again.

I had this problem years ago and it just stopped. Now it seems to be back. Don't know what to do?
 
So sometimes my computer will suddenly go black and say NO OPERATING SYSTEM DETECTED

when this happens I turn the computer off, unplug the HDD (os is on ssd), turn on the computer, sometimes it says no hard drive detected and reboots by itself and the computer will start and find windows.

then i turn off the pc, plug in the hdd again and turn on my pc and everything works.

Hours or a day later it suddenly does it again.

I had this problem years ago and it just stopped. Now it seems to be back. Don't know what to do?
Have you tried moving the SSD to a different SATA port?
 
Jan 31, 2019
4
0
10
0
The only other thing I would do is try a different cable if this doesn't work.
I changed the placing of the cable on the motherboard and turned on PC. It says os not found. I unplugged hdd and it found it.

I changed the placing of the ssd again and then also changed the placing of the hdds motherboard placing and it booted fine.

Actually as I was typing this I found a cable so I changed the ssd cable to a new one and it booted fine. Time will only tell if it the issue happens again.
 
I changed the placing of the cable on the motherboard and turned on PC. It says os not found. I unplugged hdd and it found it.

I changed the placing of the ssd again and then also changed the placing of the hdds motherboard placing and it booted fine.

Actually as I was typing this I found a cable so I changed the ssd cable to a new one and it booted fine. Time will only tell if it the issue happens again.
Let's hope that it was just a faulty cable.
 

ASK THE COMMUNITY

TRENDING THREADS