SSD on Asus laptop problems

Sithlorde

Honorable
Dec 30, 2013
1
0
10,510
0
I have been battling an issue for some time and I'm running out of ideas. I'm throwing this question out as a hail mary to possibly get lucky and find a solution. Here is a summary of the problem, I'll put more details below.

I have attempted to replace the HD in my ASUS K70IC series notebook with no success. I have tried a Toshiba SSD (total failure) and a Corsair SSD which was more successful but still experience some issues. The current problem on the Corsair SSD is that periodically the laptop HANGS for anywhere from a few to several seconds (2 - 30). There are no obvious processes running to cause the issue and no error messages, it simply becomes unresponsive.

Has anyone fought (and won) a battle like this? I appreciate any tips you can give me. Below is a more detailed description of the things I have tried.

Thanks in advance!

Details:
First attempt was with a Toshiba SSD. I was unable to successfully install any version of Windows (7, Vista, XP). I have tried the obvious things (BIOS update, change the AHCI and IDE modes, etc). With no luck. I assumed it was a bad drive, so I RMA'd it but had the same problem with the replacement drive. I put the Toshiba SSD into my wife's Dell laptop and it worked perfectly. Installed Win7 in about 30 minutes, pulled the drive from the Dell and put it back in the Asus and tried to boot to Windows, nothing but Blue Screen of Death on boot.

Pulled the Corsair SSD out of my wife's Dell and put it in the Asus, and was able to install Ubuntu and it seemed to work perfectly although I didn't use Ubuntu for more than a few hours at most. I was then able to wipe the drive, and install Windows 7 successfully. I can boot into Windows and even install some applications. It ALMOST works fine. I experience an issue where the machine will hang/lockup for several seconds and it seems to happen several times per day. I installed the Corsair Tool to try to update the SSD, but that had no impact on performance.
 

ASK THE COMMUNITY