Question Starting computer with more than one monitor plugged in gives black screen on all of them ?

Oct 11, 2020
5
0
10
0
hello all, I've had 3 monitors for awhile now and have not experienced any issues with them so far,
just recently upgraded to a ryzen 7 5800x and a AIO cooler. Now when i start my computer and all monitors are plugged in they all have black screens (peripherals turn on, fans spin up)
I actually have to turn my computer off, unplug two of my monitors then it works fine, then plug the monitors back in.
Obviously I don't want to have to do this everytime i start my pc, anyone know any solutions?
 

Lutfij

Titan
Moderator
When you say upgraded to the Ryzen 7 5800x and AIO, what did you upgrade from? Please state the specs to your build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

include the age of the PSU as well if you're recycling the unit. If the storage was carried over from the older build, and the motherboard was changed, did you reinstall the OS on the new platform? Can you get into BIOS and see what BIOS version you're on at the time of writing?
 
Oct 11, 2020
5
0
10
0
When you say upgraded to the Ryzen 7 5800x and AIO, what did you upgrade from? Please state the specs to your build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

include the age of the PSU as well if you're recycling the unit. If the storage was carried over from the older build, and the motherboard was changed, did you reinstall the OS on the new platform? Can you get into BIOS and see what BIOS version you're on at the time of writing?
Upgraded from ryzen 5 3600

gpu: rtx 3070
case: meshify c
motherboard: msi b550 a pro
psu: corsair rm 750
os: windows 10
ram: 3200 g skill kit
ssd: Crucial BX500 1TB X3
only upgrade was the cpu.
three monitors before hand was working fine. Sometimes when i sleep computer then turn it on it works but if i turn it on i have to unplug all monitors excetp one then wait
Weird thing is when all monitors are plugged in, and the monitors dont show anything, the peripherals dont light up or anything but case fans spin
 

ASK THE COMMUNITY

TRENDING THREADS