Question Steam is causing windows to freeze

Jan 8, 2020
4
0
10
0
First time poster so not sure if this is the right place for this. Over the last few days whenever I launch steam it will make it only as far as the library page before freezing up and bringing windows down with it. I can't do anything after this happens and have to force a reboot. After trying a bunch of troubleshooting solutions on my own over the past few days I've finally narrowed it down to what I think is either my graphics card on the fritz or my drivers conflicting with steam. When I disable my gpu with device manager and switch to onboard graphics, the problem goes away.

At this point though I've kind of hit a wall. Even though I think I know that's the issue I'm not sure how to resolve it. Any suggestions would really be appreciated and I can provide any additional info upon request. Thanks in advance.

System Specs:
Windows 10
Mobo: Asus z97-A
RAM: 2x 4gb Ballistix Sport
CPU: i7-4790
GPU: Radeon R9270x
500w psu
(If anymore info is needed feel free to ask)
 
Jan 8, 2020
4
0
10
0
Try starting steam in safe mode with networking and log in. If it runs in there then you have a software conflict somewhere.
Yeah that's one of things I originally tried and it did work in safe mode. That's why I think I've narrowed down to graphics drivers or a my card being shot, it's about 5 years old now. I'm wondering if I should just keep rolling back through available gpu drivers until one works or if I should find a way to scan for damge in my card?
 
Jan 8, 2020
4
0
10
0
Do you have any entires to coincide with Steam and windows closing in computer management event viewer?
Letting windows install the driver didn't work and I'm not overclocking or altering my CPU in any way.
Not sure what I should be looking for in the event viewer. A ctrl-f for steam only brings up two results both saying "The following application attempted to veto the shutdown: Steam.exe."
 
Jan 8, 2020
4
0
10
0
UPDATE:

Someone on the steam forums helped resolve the issue by having me disable some of the new UI graphics settings as well as the hardware acceleration settings. They also had me repair the library folders through the steam download settings. I did them all in one step so I'm not sure which actually solved the problem.

Thanks for your help too though, Fix_that_Glitch!
 
UPDATE:

Someone on the steam forums helped resolve the issue by having me disable some of the new UI graphics settings as well as the hardware acceleration settings. They also had me repair the library folders through the steam download settings. I did them all in one step so I'm not sure which actually solved the problem.

Thanks for your help too though, Fix_that_Glitch!
Steam causes more problems than windows! Glad you resolved your issue.(y)
 

ASK THE COMMUNITY

TRENDING THREADS