Question Strange issues with a new M.2 drive, diagnostics come back with nothing.


Aug 17, 2015
Hey guys,

I've been chipping away at this issue for the past week or two and I figure I could try here before handing in my drive and possibly PC into a repair shop.

I bought and installed an M.2 drive and a CPU cooler two weeks ago. The short of it is that I've been getting crashes to a black screen occasionally, tons of errors in event viewer, and just general weirdness. I don't know what's causing it. I did the chdsk thing and it came out completely clean, I did the windows auto repair thing (sfc /scannow or whatever it is), and I've checked online, but I can't seem to figure out what the issue is.

First thing I did after installing the M.2 was install and play Dwarf Fortress. I crashed to an unresponsive black screen and had to flip the switch on my PSU to turn my PC off. Event viewer said something about a hypervisor VSM error. The same thing happened with Overwatch until recently, when I looked online, changed some BIOS settings, and seemingly fixed that error. Game crashed anywhere from 10 minutes to 2 hours of play. Haven't played enough to say that it's gone away for sure.

Yesterday, a new problem emerged. I installed Apex Legends to the drive and had played several hours over the past couple of days without issue. Then, after maybe an hour of playing yesterday, my game froze up. I went into task manager and ended the thing, which took a few tries to do for some reason. I tried to boot up the game but it wouldn't boot. Tried verifying and then uninstalling the game on steam, but it just wouldn't do anything.
Looked into event viewer and got several error codes and warnings. Let me know if there's any easy way to show you guys exactly what I got. There is a very long list. Namely I got event 1000 and 1005, on task manager and apex legends respectively. It said that task manager was closed because of an error with apex. Preceding that I got dozens of warnings consiting of stuff like (event 51 disk) "an error was detected on hard disk 2 (my m.2 drive) during a paging operation", or event 140, nfts, "System failed to flush data to the transaction log. Corruption may occur in VolumeId: F:, DeviceName: \Device\HarddiskVolume7.".
Also very important to mention!! I couldn't reinstall the thing or anything until i restarted my computer. Also, when Apex was having issues, I couldn't access a folder in that M.2 drive for some reason. Not even steam, just a folder where I had an edited video. Gave me a pop up error saying, "Location is not available, a device which does not exist was specified". Again, no CHDSK errors so I don't know what the hell is going on.

All that seems to suggest an issue with the drive, but I ran that CHDSK thing and it came up with nothing. According to its test, everything is just fine. I think my next step is to return the drive and swap it out for a new one and see if that fixes things (if the vendor can find anything wrong with it, which I worry about); I could also clean install Windows if that's what's giving me trouble, though the sfc /scannow also came up with nothing.

Drivers/firmware is up to date according to WD's software and Windows.

The other thing this could be, is my CPU. Or my motherboard, I guess? I did a messy swap of my CPU cooler in which my CPU wasn't warm enough so it got stuck to the cooler and I had to blowdry it and then separate it. I don't think I bent any pins or anything, but it also wouldn't completely surprise me if it turned out that the CPU was damaged in such a way that the M.2 drive wasn't communicating properly with it or something. But I haven't had any CPU issues that I'm aware of, and I'd imagine that if it were that sort of thing, I might not boot or be able use the drive at all. The weird, almost brownout-like crashes that I seem to have maybe fixed could have been a PSU thing, but I doubt it for a variety of reasons (doesn't happen if i stress test things, no issues on boot, no weird noises except the occasional faint buzzing from the PSU).

That's probably a lot, and I'd love to give any more info or clarify things for y'all if any of you want to take a stab at this. Thanks.

CPU: 5600G
RAM: 2x8GB Crucial Vengeance (i think)
MOBO: B550m aurous pro
PSU: Corsair 650W, I believe
GPU: Gigabyte RX 6600 Eagle
Storage: Samsung 850 Evo 500GB, WD Blue 1TB 7200RPM HDD, WD SN770 1TB M.2 SSD (the problem drive)
Windows 10, updated to the latest version.