Question Strange Memory Management BSOD, not sure what is causing it

RCguitarist

Distinguished
So I just 2 days ago developed an almost constant memory management BSOD. My pc has never been prone to issues, is showroom clean inside and is built with quality parts throughout. Has always run flawlessly. But 2 days ago, after about 4 hours of gaming, I was simply browsing amazon and I got the BSOD siting memory management stop code. it rebooted and then started BSODing every time it tried to boot up windows and would get into a BSOD loop with every BSOD being the same stopcode. This is constant. I can sometimes get windows to fire up if I keep restarting the pc over and over. and when it starts I can get it to even run games. I tried stress testing it and no BSOD, but if I restart or shut down my PC, its about a 90% chance it will BSOD upon starting back up. Below I am listing everything I have tried so far as well as the dump file text. Also of note, I have not added any new hardware or software to my PC in quite a while and I keep my windows, GPU, antivirus etc up to date.

What I have tried:
  • Sfc scan
  • Windows memory diagnostic (said no errors)
  • Memtest86 (did 1 pass, said no errors)
  • Reseated RAM
  • Removed RAM modules (have 4) one at a time to see if one of them being removed would resolve the BSOD, it BSOD'd each time, so no change there
  • Reverted last windows update (no change)
  • Reapplied last windows update (no change)
  • Turned off virtual memory and told it not to make a page file, restarted, then turned it back on (no change)
  • Pushed and held the DRAM OK button on the motherboard during a startup
  • Bios and windows are both seeing my full 12GB of memory
Other interesting things of note:
  • If I have all 4 sticks of RAM in, it BSODs 100% of the time. If I remove 1 stick (any 1 stick) it has a 30%-ish chance of starting up and running.
  • Once it actually gets into windows, the pc runs fine. isn't sluggish or anything
Here is the dump file contents:

Microsoft (R) Windows Debugger Version 10.0.20153.1000 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\WINDOWS\MEMORY.DMP]
Kernel Bitmap Dump File: Full address space is available

Symbol search path is: srv*
Executable search path is:
Windows 10 Kernel Version 18362 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Edition build lab: 18362.1.amd64fre.19h1_release.190318-1202
Machine Name:
Kernel base = 0xfffff80708600000 PsLoadedModuleList = 0xfffff80708a461b0
Debug session time: Wed Feb 24 09:51:44.176 2021 (UTC - 6:00)
System Uptime: 0 days 0:00:20.858
Loading Kernel Symbols
...............................................................
................................................................
................................................................
...................
Loading User Symbols

Loading unloaded module list
......
For analysis of this file, run !analyze -v
nt!KeBugCheckEx:
fffff807087c3b20 48894c2408 mov qword ptr [rsp+8],rcx ss:0018:fffffa0566786d10=000000000000001a
0: kd> !analyze -v
***
  • *
  • Bugcheck Analysis *
  • *
***

MEMORY_MANAGEMENT (1a)
# Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000001240, The subtype of the bugcheck.
Arg2: ffffbe0c151572f0
Arg3: ffff8954c3feefd0
Arg4: 0000200000000080

Debugging Details:
------------------


KEY_VALUES_STRING: 1

Key : Analysis.CPU.mSec
Value: 4156

Key : Analysis.DebugAnalysisProvider.CPP
Value: Create: 8007007e on DESKTOP-6IKHTSC

Key : Analysis.DebugData
Value: CreateObject

Key : Analysis.DebugModel
Value: CreateObject

Key : Analysis.Elapsed.mSec
Value: 4154

Key : Analysis.Memory.CommitPeak.Mb
Value: 79

Key : Analysis.System
Value: CreateObject

Key : WER.OS.Branch
Value: 19h1_release

Key : WER.OS.Timestamp
Value: 2019-03-18T12:02:00Z

Key : WER.OS.Version
Value: 10.0.18362.1


ADDITIONAL_XML: 1

OS_BUILD_LAYERS: 1

BUGCHECK_CODE: 1a

BUGCHECK_P1: 1240

BUGCHECK_P2: ffffbe0c151572f0

BUGCHECK_P3: ffff8954c3feefd0

BUGCHECK_P4: 200000000080

BLACKBOXBSD: 1 (!blackboxbsd)


BLACKBOXNTFS: 1 (!blackboxntfs)


BLACKBOXWINLOGON: 1

PROCESS_NAME: aswidsagent.exe

LOCK_ADDRESS: fffff80708a60a00 -- (!locks fffff80708a60a00)

Resource @ nt!PiEngineLock (0xfffff80708a60a00) Exclusively owned
Contention Count = 18
NumberOfExclusiveWaiters = 1
Threads: ffffbe0c0f157040-01<*>

Threads Waiting On Exclusive Access:
ffffbe0c0f60b040
1 total locks

PNP_TRIAGE_DATA:
Lock address : 0xfffff80708a60a00
Thread Count : 1
Thread address: 0xffffbe0c0f157040
Thread wait : 0x536

STACK_TEXT:
fffffa0566786d08 fffff8070884146e : 000000000000001a 0000000000001240 ffffbe0c151572f0 ffff8954c3feefd0 : nt!KeBugCheckEx
fffffa0566786d10 fffff8070c4e638d : ffffa987fddfa000 0000000000000000 ffff8954c3feefd8 0000000000000000 : nt!MmBuildMdlForNonPagedPool+0x1472fe
fffffa0566786dc0 fffff8070c4e2ce7 : ffffbe0c16666000 fffffa0566786ef0 0000000000000200 00000000000000c0 : vsflt53+0x1638d
fffffa0566786e80 fffff8070c4d5fe7 : 0000000000000000 ffffa987fddfa000 0000000000000001 ffffbe0c0d3ff920 : vsflt53+0x12ce7
fffffa0566786ec0 fffff8070c4d6bb1 : ffffbe0c16666170 0000000000000000 0000000000000001 ffffbe0c0d3ff920 : vsflt53+0x5fe7
fffffa0566786f90 fffff8070c4d84bc : ffffbe0c11c24210 ffffbe0c16666010 ffffbe0c0d3dd280 0000000000000000 : vsflt53+0x6bb1
fffffa0566786fe0 fffff8070c4d7ff4 : ffffbe0c11c24210 ffffbe0c16666010 ffffbe0c0d3dd280 0000000000000000 : vsflt53+0x84bc
fffffa0566787020 fffff8070c4dfd26 : 0000000000000001 00000000c00000bb ffffbe0c11c24210 0000000060000001 : vsflt53+0x7ff4
fffffa05667870a0 fffff8070c4dfaf4 : ffffbe0c11c24210 ffffbe0c11c24210 ffffbe0c11c24210 ffffbe0c0d3dd280 : vsflt53+0xfd26
fffffa05667870d0 fffff8070c4e0936 : fffffa0566787158 0000000000000000 fffff8070c4d1ef0 ffffbe0c0d3dd280 : vsflt53+0xfaf4
fffffa0566787100 fffff8070c4df9a1 : ffffbe0c152b7e20 0000000000005150 ffffbe0c0d3dd280 ffffbe0c11c24210 : vsflt53+0x10936
fffffa0566787130 fffff8070c4dc4f2 : ffffbe0c152b7e20 fffffa0566787370 ffffbe0c16666010 ffffbe0c152b7f70 : vsflt53+0xf9a1
fffffa0566787170 fffff80708637159 : fffff80708600000 fffff80708638ba6 ffffffffffffffff ffffbe0c16666010 : vsflt53+0xc4f2
fffffa05667871a0 fffff8070d591a67 : fffff8070896f468 fffff80708bbe8c5 ffffffff0000ffff 0000000000000000 : nt!IofCallDriver+0x59
fffffa05667871e0 fffff8070d5a2399 : ffffbe0c169d5370 ffffbe0c16666010 ffffa987f2faf170 ffffa987f2faf170 : CLASSPNP!ClassSendIrpSynchronous+0x67
fffffa0566787240 fffff8070d5d87f0 : ffffbe0c169d5370 0000000000010000 00000000c0000002 0000000000000005 : CLASSPNP!ClassForwardIrpSynchronous+0x39
fffffa0566787270 fffff8070d5917c3 : ffffa987f2800340 00000000000000ff ffffbe0c16666010 0000000000000000 : CLASSPNP!ClassDispatchPnp+0x390
fffffa05667873f0 fffff80708637159 : fffffa05667876c0 0000000000000053 0000000000000103 0000000000000000 : CLASSPNP!ClassGlobalDispatch+0x23
fffffa0566787420 fffff8070872a64e : 0000000000000001 0000000000000000 0000000000000000 fffffa05667876c0 : nt!IofCallDriver+0x59
fffffa0566787460 fffff80708cd4fe1 : 0000000000000000 0000000000000005 0000000000000000 fffffa05667876c0 : nt!IoSynchronousCallDriver+0x4e
fffffa05667874c0 fffff8070c569721 : ffffa987fc73ede0 0000000000000000 ffffa987fc73ed60 fffff8070896e0a9 : nt!IoForwardIrpSynchronously+0x41
fffffa05667874f0 fffff8070c57b620 : ffffbe0c16666010 ffffbe0c166661b8 ffffbe0c16666010 ffff39117139c97c : partmgr!PmStartDevice+0x75
fffffa05667875c0 fffff8070c561eef : ffffbe0c16666010 ffffbe0c169d5d60 ffffbe0c16666200 00000000000000ff : partmgr!PmPnp+0x120
fffffa0566787610 fffff80708637159 : ffffa98700000000 0000000000000000 fffff80708cf9fa0 fffff80708d06d56 : partmgr!PmGlobalDispatch+0x1f
fffffa0566787640 fffff8070d66131d : fffffa05667876c0 fffff80708977760 fffffa05667876e8 fffffa0566787718 : nt!IofCallDriver+0x59
fffffa0566787680 fffff8070d661228 : ffffbe0c169d5c10 ffffbe0c16666010 0000000000000000 0000000000000000 : aswArDisk+0x131d
fffffa05667876f0 fffff80708637159 : ffffbe0c169d5c10 ffffbe0c16666010 ffffbe0c16666010 fffffa0566787860 : aswArDisk+0x1228
fffffa0566787740 fffff80708d18e46 : ffffbe0c1698d060 ffffbe0c15ac1e40 0000000000000000 0000000000000000 : nt!IofCallDriver+0x59
fffffa0566787780 fffff8070869983a : ffffbe0c1698d060 0000000000000000 ffffbe0c15ac1e40 fffff80700000000 : nt!PnpAsynchronousCall+0xea
fffffa05667877c0 fffff8070875898c : 0000000000000000 ffffbe0c1698d060 fffff807087454c0 fffff807087454c0 : nt!PnpSendIrp+0x5e
fffffa0566787830 fffff80708d18128 : 0000000000000000 0000000000000000 ffffbe0c15ac1e40 0000000000000000 : nt!PnpStartDevice+0x88
fffffa05667878c0 fffff80708d17ff7 : ffffbe0c1698c890 0000000000000000 0000000000000001 fffff80708745946 : nt!PnpStartDeviceNode+0xec
fffffa0566787950 fffff80708d02a1c : ffffbe0c1698c890 fffffa0566787a18 0000000000000002 0000000000000001 : nt!PipProcessStartPhase1+0x6f
fffffa05667879a0 fffff80708d200bc : ffffbe0c13fd2d00 fffff8070863ee01 fffffa0566787ab0 fffff80700000002 : nt!PipProcessDevNodeTree+0x3b0
fffffa0566787a60 fffff8070875d747 : 0000000100000003 ffffbe0c15807cb0 ffffbe0c13fd2d80 ffffbe0c13fd2d80 : nt!PiProcessReenumeration+0x88
fffffa0566787ab0 fffff80708659d35 : ffffbe0c0f157040 ffffbe0c0d887cb0 fffff80708a5f2c0 ffffbe0c0d887cb0 : nt!PnpDeviceActionWorker+0x207
fffffa0566787b70 fffff80708733585 : ffffbe0c0f157040 0000000000000080 ffffbe0c0d871040 00000405b59bbfff : nt!ExpWorkerThread+0x105
fffffa0566787c10 fffff807087cb128 : ffffd08195d62180 ffffbe0c0f157040 fffff80708733530 0000000000000014 : nt!PspSystemThreadStartup+0x55
fffffa0566787c60 0000000000000000 : fffffa0566788000 fffffa0566782000 0000000000000000 0000000000000000 : nt!KiStartSystemThread+0x28


SYMBOL_NAME: vsflt53+1638d

MODULE_NAME: vsflt53

IMAGE_NAME: vsflt53.sys

STACK_COMMAND: .thread ; .cxr ; kb

BUCKET_ID_FUNC_OFFSET: 1638d

FAILURE_BUCKET_ID: 0x1a_1240_vsflt53!unknown_function

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {5ea660ab-7d46-79bc-889e-2be6f6839cc1}

Followup: MachineOwner
---------
 

RCguitarist

Distinguished
Update:
After posting this I looked up the file mentioned in the dump file called vsflt53.sys. It looks to be an acronis driver from the program Acronis true image that I used years ago to make a drive image when I bought a new, larger SSD for my C drive. I uninstalled the software, removed the driver from the registry and deleted that driver file. Now my pc has started fine twice with ALL FOUR sticks of RAM in it (was a 100% BSOD rate until just now. I will restart several more times and report back.
 

RCguitarist

Distinguished
Latest update:
So now when it starts, my task bar flashes for about 20 seconds weirdly and then my desktop appears. And xbox gamepass games no longer will launch even though the windows store and the gamepass app both say that the game is installed.
 

ASK THE COMMUNITY

TRENDING THREADS