Stuck in blank screen.

Nov 5, 2018
1
0
10
0
at first the problem was that i was stuck in efi shell, so i shutdown the computer, disconnected all terminals as if i was assembling a new system unit and then when i booted it,
it didnt go to efi shell, instead it stopped at a blank black? screen (i cant describe the color) right after the msi logo.
pls correct me if im stating this wrong im still new to this.

-motherboard: MSI Military Class 4
-hdd: Seagate Barracus 1.5tb
-ram: DDR3 4gb
 

Lutfij

Titan
Moderator
List your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Military class 4 is not the model of the board, rather the feature that's on it. Try and remove the CMOS battery and replace it after 15 mins and then try powering the system back up. Make sure all connections are secure and snug in their connectors.
 

Spinachy

Reputable
Feb 17, 2016
162
1
4,765
29
You do not say if this is a system you are just putting together from components, or, if it used to work but has now stopped. For "no display" problems, I suggest double checking your wiring.

"Stuck in EFI Shell" usually means that the bootup sequence cannot find a bootable device. This causes the computer to just display the UEFI screen every time it is rebooted. I suggest :
1) Get the machine back to the state where it is "Stuck in the EFI Shell", as this is further along that you are getting right now.
2) Check the connections to your hard drive (Power cable and SATA cable)
3) Check the boot sequence in your UEFI "boot" menu, to ensure that the boot drive is first

 

ASK THE COMMUNITY

TRENDING THREADS