Stuttering and/or BSOD DPC_WATCHDOG_VIOLATION

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0
Hi all.

This issue started quite a while back up to a year or more. It would be random failures to boot with the "ntoskrnl.exe" being listed as corrupt or missing. In the past doing a reboot would get me into the OS, I had no issues once the PC was in windows.

Now, recently while playing DCS in the FA-18 hornet the game began to stutter, the audio crackled, the PC became unresponsive and finally displayed a BSOD with "DPC_WATCHDOG_VIOLATION".

Now my PC will do this randomly. It has happened just browsing this forum for example. Sometimes I get away with some severe stuttering and audio artifacts for any time between 5 and 30 seconds then it comes good, other times it will hang indefinitely, and others it will BSOD.
It will happen watching videos on and offline as well, I have tried watching the videos off of both my RAID drives and my OS SSD.

The crash seems to occur quickly when playing a game called OSU. The audio will loop, and the frames will loop as well.
Interestingly the UI in the game does not freeze, for instance; the combo counter will fall to zero, and not get stuck where it was like the cursor and playing field does. It will then either BSOD, or allow me to escape the game.

I tried runnining OSU off of a RAM disk (I thought maybe a hard drive or SSd issue), same problem.

I've done a lot of troubleshooting on my own and have got nowhere.
This is what I have tried thus far.

- Disabling SLI
- Updated BIOS
- Updated intel rste drivers (hardware raid)
- Clean Re-install of windows 10
- Removed all OC's from my hardware
- Ran Prime 95 for several hours no crash
- Ran 3D Mark TimeSpy for several hours no crash
- Updated Samsung SSD Firmware
- Updated Drivers for SSD
- Clean install of graphics divers
- Took machine to local IT repair shop, stress tested all components - pass (they never experienced a crash or hang - which led me to believe my power delivery at home was the cause)
- (decided to check some things myself), bought a multimeter and tested PSU
- Swapped out my old power extention leads and power-boards
- Updated my Sound Blaster driver

Perhaps its peripheral? Though I believe nothing I have connected to the PC could draw enough power to be an issue. I have connected
- one WD Elements 107C 4TB external (Has its own power) USB 3.0
- Razer Blackwidow keyboard 2x USB 2.0
- Razer Ouroboros mouse USB 2.0
- Logitech Z200 stereo speakers (Plugged into GameBlaster sound card) (rarely used)
- Logitech G35 Headset USB 2.0
- ASUS VG278HE monitor (Dual link DVI into top GPU)

Also worth noting temperatures are not an issue, I have watercooled CPU and GPU's, their temps never reach more than 60c.

I am at my wits end, I have no expertise in this sort of thing and frankly am close to binning this damned thing.

My PC
OS: Windows 10 Home 64-bit
Mobo: ASROCK X79 Extreme 9.
GPU: 2x EVGA GeForce GTX 780 in SLi -(tested SLi off still crash)
CPU: Intel i7 3930K @3.2Ghz
RAM: 4x4GB DDR4 2400Mhz Corsair Dominator Platinum (speccy says DDR3 1200Mz?)
Storage: 1x Samsung 850 Evo 500GB, 3x Toshiba DT01ACA100 1TB 7200 RPM in RAID 0, 1x External WD Elements 107C 4TB
Audio: ASRock Game Blaster

--------------------------------------- Dump txt below ---------------------------------

Crash Dump Analysis provided by OSR Open Systems Resources, Inc. (http://www.osr.com)
Online Crash Dump Analysis Service
See http://www.osronline.com for more information
Windows 8 Kernel Version 17763 MP (12 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 17763.1.amd64fre.rs5_release.180914-1434
Machine Name:
Kernel base = 0xfffff807`4eab3000 PsLoadedModuleList = 0xfffff807`4eecda50
Debug session time: Wed Jan 2 11:32:00.140 2019 (UTC - 5:00)
System Uptime: 0 days 0:06:37.859
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

DPC_WATCHDOG_VIOLATION (133)
The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL
or above.
Arguments:
Arg1: 0000000000000001, The system cumulatively spent an extended period of time at
DISPATCH_LEVEL or above. The offending component can usually be
identified with a stack trace.
Arg2: 0000000000001e00, The watchdog period.
Arg3: fffff8074eff4380
Arg4: 0000000000000000

Debugging Details:
------------------

TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2

DEFAULT_BUCKET_ID: WIN8_DRIVER_FAULT

BUGCHECK_STR: 0x133

CURRENT_IRQL: 0

LAST_CONTROL_TRANSFER: from fffff8074ed0cc4b to fffff8074ec64b40

STACK_TEXT:
fffff807`5126d358 fffff807`4ed0cc4b : 00000000`00000133 00000000`00000001 00000000`00001e00 fffff807`4eff4380 : nt!KeBugCheckEx
fffff807`5126d360 fffff807`4ebdd4cf : 0000315a`8ff08eb1 fffff807`4dae2180 00000000`00000282 00000000`00006377 : nt!KeAccumulateTicks+0x12c10b
fffff807`5126d3c0 fffff807`4ea1e47c : 00000000`00000000 fffff807`4ea846e0 fffff807`5126d830 fffff807`4ea84790 : nt!KeClockInterruptNotify+0xcf
fffff807`5126d6e0 fffff807`4eb08115 : fffff807`4ea846e0 fffff807`4ea846e0 fffff807`5126d860 fffff807`4ea84790 : hal!HalpTimerClockIpiRoutine+0x1c
fffff807`5126d710 fffff807`4ec6653a : fffff807`5126d830 fffff807`4ea846e0 fffff807`5126db50 fffff807`4ebe104f : nt!KiCallInterruptServiceRoutine+0xa5
fffff807`5126d760 fffff807`4ec66a87 : fffff807`5126d8f0 fffff807`4ec66a87 fffff807`4dae2180 fffff807`545777dc : nt!KiInterruptSubDispatchNoLockNoEtw+0xfa
fffff807`5126d7b0 fffff807`5484d345 : fffff807`00000020 fffff807`5126d960 fffff807`5126db50 fffff807`54577e64 : nt!KiInterruptDispatchNoLockNoEtw+0x37
fffff807`5126d940 fffff807`00000020 : fffff807`5126d960 fffff807`5126db50 fffff807`54577e64 fffff807`5126db50 : nvlddmkm+0x4dd345
fffff807`5126d948 fffff807`5126d960 : fffff807`5126db50 fffff807`54577e64 fffff807`5126db50 ffffad89`c1680000 : 0xfffff807`00000020
fffff807`5126d950 fffff807`5126db50 : fffff807`54577e64 fffff807`5126db50 ffffad89`c1680000 ffffad89`c169e050 : 0xfffff807`5126d960
fffff807`5126d958 fffff807`54577e64 : fffff807`5126db50 ffffad89`c1680000 ffffad89`c169e050 fffff807`5454b08a : 0xfffff807`5126db50
fffff807`5126d960 fffff807`5126db50 : ffffad89`c1680000 ffffad89`c169e050 fffff807`5454b08a ffffad89`c16a6000 : nvlddmkm+0x207e64
fffff807`5126d968 ffffad89`c1680000 : ffffad89`c169e050 fffff807`5454b08a ffffad89`c16a6000 00000000`00000000 : 0xfffff807`5126db50
fffff807`5126d970 ffffad89`c169e050 : fffff807`5454b08a ffffad89`c16a6000 00000000`00000000 00000000`00000001 : 0xffffad89`c1680000
fffff807`5126d978 fffff807`5454b08a : ffffad89`c16a6000 00000000`00000000 00000000`00000001 00000000`00000140 : 0xffffad89`c169e050
fffff807`5126d980 ffffad89`c16a6000 : 00000000`00000000 00000000`00000001 00000000`00000140 ffffad89`c1680000 : nvlddmkm+0x1db08a
fffff807`5126d988 00000000`00000000 : 00000000`00000001 00000000`00000140 ffffad89`c1680000 ffffad89`c1680000 : 0xffffad89`c16a6000


STACK_COMMAND: kb

FOLLOWUP_IP:
nvlddmkm+4dd345
fffff807`5484d345 4533c0 xor r8d,r8d

SYMBOL_STACK_INDEX: 7

SYMBOL_NAME: nvlddmkm+4dd345

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nvlddmkm

IMAGE_NAME: nvlddmkm.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 5c0f578b

FAILURE_BUCKET_ID: X64_0x133_nvlddmkm+4dd345

BUCKET_ID: X64_0x133_nvlddmkm+4dd345

Followup: MachineOwner
---------
 
kind of a long timeout period for a video driver.

basically to debug this you would have to change the memory dump type to kernel rather than a minidump. then provide the next kernel memory dump file C;\windows\memory.dmp

IE put it on a cloud server, share the file for public access and post a link.

you might also, attempt a fix by going to your motherboard vendors website and update the motherboard sound driver. Add on audio cards can conflict with motherboard sound driver, GPU sound drivers, and CPU sound drivers. you might also go to windows control panel, device manager and disable any sound devices that do not have a speaker connected to them.
 

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0


Thanks John,
I have changed the dump type to kernel and disabled all playback devices except for my sound card and headset. As for the MoBo drivers I believe the ASRock X79 Extreme 9 shipped with the GameBlaster sound card. I have the driver on their website that I found here. https://www.asrock.com/mb/Intel/X79%20Extreme9/index.asp#Download

I will post when/if another crash occurs.

Update: PC crashed again whilst running OSU - Here is the zipped minidump https://1drv.ms/u/s!ArMiZzo4hhpEh1CCCdwIYW6CJOLU
Here is the zipped memory dump, https://1drv.ms/u/s!ArMiZzo4hhpEh1FTEktLJB3GbJcq
 
your usb 3 drivers get its support from the bios but these driver are not the ones that came with your motherboard. (as far as i can tell)
you might consider, disabling the usb support in bios and adding a add on usb card.
or roll back your driver version to one that came with your motherboard. (old windows 8 driver)
---------------------
remove the old nvidia driver and see if you still get the problem. (try this first)
based on the timeout I think it is going to be related to the texas instruments driver.
Will see if i can find a internal log

----------------
TUSB73X0 FILTER DRIVER
TEXAS INSTRUMENTS, INC.
looks like SuperSpeed USB 3.0 4–port xHCI host controller (add in card)
\SystemRoot\System32\drivers\TIxHCIlfilter.sys Fri Jul 17 12:42:27 2015
\SystemRoot\System32\drivers\TIxHCIufilter.sys Fri Jul 17 12:42:11 2015
looks like various known bugs in the driver: http://www.ti.com/lit/er/sllz076/sllz076.pdf

nVidia System Utility Driver (unexpected driver, too old)
\SystemRoot\system32\DRIVERS\nvoclk64.sys Tue Sep 15 14:59:25 2009


machine info:
BIOS Version P4.00
BIOS Starting Address Segment f000
BIOS Release Date 02/14/2014


Processor Version Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz
Manufacturer ASRock
Product X79 Extreme9

Processor Voltage 80h - 0.0V
External Clock 100MHz
Max Speed 4000MHz
Current Speed 3200MHz
 

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0


I downloaded DDU and Nvidia's latest drivers, loaded the OS in safe mode ran DDU, rebooted and then installed the Nvidia driver while offline.
[strike]The nvoclk64.sys file remains, I am unsure how to remove it. If I could get some assistance with this it would be appreciated.[/strike] It was the Nvidia nTune utility. I have uninstalled it now.

I've found a USB3.0 driver specifically for my MoBo from 2011, 4 years earlier than the present drivers, (Asrock X79 Extreme9 TI USB 3.0 Driver 1.12.9)
I've uninstalled the two original TEXAS INSTRUMENTS drivers via device manager and installed the above driver.

I have so far experienced an improvement but not yet fully resolved - I am yet to experience a BSOD but I am still encountering the looped audio and frames while gaming, only now it seems to get stuck for only a few seconds at a time 5-15 seconds.
Thanks for your help so far John.
 
go into device manager and look for any devices that are not installed, update or remove the device to let windows plug and play reinstall them.

the kernel memory dump is not working correctly, I can not access info that would normally be there. you might want to do a rootkit scan and a malwarebytes scan.

you might want to change to a full memory dump.


remove this driver:
\SystemRoot\system32\DRIVERS\nvoclk64.sys Tue Sep 15 14:59:25 2009
(I just have no idea why this would be installed on your system)

I would also remove each of these:
GPUZ.sys
cpuz147_x64.sys
magdrvamd64.sys

and see if you get better results

you can use autoruns from here:
https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns
and disable the drivers and reboot. uncheck the driver to prevent it from loading.
delete the driver entry to make the changes permanent.

you might also look for a update to your sound blaster driver from 2013.

I did not see a gpu sound driver installed. generally you might install it and then disable it in device manager.
 

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0
I have changed the dump type to full memory dump - will update when/if a crash occurs.

I downloaded Malwarebytes Anti-Rootkit BETA v1.10.3.1001 and ran the Scan System function, no issues detected.

I also downloaded and installed Malwarebytes Premuim Trial 3.6.1 and ran a Scan, it found two instances of drvagent64.sys from file.net, I quarantined and deleted them.

I uninstalled a bunch of hardware monitoring apps and verified the following drivers are no longer installed:
GPUZ.sys
cpuz147_x64.sys
magdrvamd64.sys
nvoclk64.sys

I also re-ran the Nvidia driver intaller to install the HD audio driver and updated the sound blaster driver via device manager.

The only part I am not confident/lack understanding to do is fiddle with removing devices from device manager. If I can get further help/clarification in what you're suggesting I do that would be great.

Thanks again for your help so far John.
 
when you remove a device using device manager, windows removes the device then windows plug and play sees that it needs a device driver and reinstalls the driver a few seconds later. most of the time this does not help but sometimes when people change hardware it does help. often you have to show remove /hidden devices in device manger to see the problem.

just see if you still bugcheck now that you have removed all of the tool related drivers.




 

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0
Just an update. I have additionally moved to a new headset, the cables on my old one were worn.

I'm still getting stuttering, though much less severe now. They are down to playable levels for gaming. They only occur for fractions of a second with hours between intervals, and no hard locks or crashes.

I will continue to update this thread as new symptoms/resolutions are discovered.

I have not made any other hardware changes other than a new USB headset.
 

3minjence

Honorable
Oct 5, 2013
14
0
10,510
0
Very late update. I believe the problem lies with one of my two video cards, when in SLI I get the issue. Running off of a single GPU seems to be stable.
I'll be taking it back to a repair shop to get them tested separately and together.
 

ASK THE COMMUNITY

TRENDING THREADS