Question Stuttering in a specific game despite being on a beefy rig

Yeldur

Reputable
Jan 28, 2017
191
22
4,695
4
Hi all,

I have a question. For reference, here is my rig:

  • Ryzen 7 5800X
  • Noctua NH-D15
  • ASUS ROG Strix X570-F
  • G.Skill Trident Z RGB 32GB DDR4-3600 CL16
  • MSI SUPRIM X RTX 3090
Note: No overclocking has been done on this rig, everything is as it is, standard (Yes, I have configured DOCP profiles for the RAM, so it is running at 3600 MHz, as it should be)

I've noticed that in a specific game I play (Total War: Attila), I see stuttering, and pretty harsh framerate drops, despite having no mods active. I even see these stutters when I set the game to Max Performance, which lowers the settings to the lowest they can go (short of texture quality, which it leaves at Ultra)

I've noticed that on the game graphical menu, it states "Video Memory: 3072MB" - Now, I know this isn't the Video Memory of my GPU, because in other games it recognises that I've got 24 (as it should) - However, I've done some reading up and it seems that this 3072MB appears to be the cap for this game..

So if I'm thinking correctly, the max amount of vRAM it can use is essentially 3GB.

Could this be causing the problem? Is the RTX 3090 simply "too powerful" to play this 2015 released game?

Other games appear to run much better, without stuttering, so the only presumption it leads me to is that it's something to do with the amount of vRAM this game is set up to use. Would my thinking be correct?
 

Yeldur

Reputable
Jan 28, 2017
191
22
4,695
4
what resolution are your playing?
2560x1440
What is the load on CPU and GPU, both during stutters and framedops but alos when the game is running fine?
Here's the GPU:
CPU:
And the results of the benchmarking, those sudden sharp dips in performance are what I'm referencing in regards to the stutter.

Note: The benchmark is not going to be perfectly aligned to the CPU/GPU stats above, I would not cross-reference these and treat them as two separate items of reference.
 

Yeldur

Reputable
Jan 28, 2017
191
22
4,695
4
I've installed a different game (Under the same platform though) - Total War: Warhammer II and that game runs smooth as butter, no issues at all. The game ran fine on my old rig, which was far more outdated in comparison to what I have currently. Certainly a perplexing issue, though from the lack of response I'm going to guess it's rather uncommon and probably isn't going to be something fixable short of playing around with bits and pieces to see if something clicks into place ;o
 

ASK THE COMMUNITY