Question Sudden consistent FPS loss in games that used to run fine.

ViralChameleon1

Honorable
Jan 31, 2015
15
0
10,510
0
So recently I've tried running certain games (Vermintide 2, Divinity 2 and Apex Legends) and found that where they would normally run at a relatively consistent 50-60fps, they now run at less than half of that regardless of what settings I adjust. Vermintide runs at 15fps now whenever I'm not looking directly at the floor or a wall (It used to run perfectly smooth during hordes but now I get less than 10fps just by moving around the lobby area). Divinity 2 which I have been playing a lot recently used to run at a solid unbudging 60fps, but now only gives me 30 or less at any given moment (also regardless of settings). And Apex is completely unplayable as well regardless of settings.

When I say "regardless of settings" I mean that in each of these games I have turned them down to the lowest possible settings and not noticed any noteworthy increases in fps. I would again like to make it clear that these games all used to run smoothly at medium-high settings as well so this was very strange and I am at my wits end here.

Other games such as Titanfall 2, Risk of Rain 2 and Genshin Impact all run as smoothly as they used to, which leads me to believe that my hardware is not the cause of this.

My Specs:
  • Ryzen 2600 CPU
  • RX 5500 XT 4GB GPU
  • 16GB 2400Mhz RAM
Things I have tried to remedy the situation so far:
  • I've checked file integrity for each of the games
  • I've reinstalled my GPU drivers
  • I've reinstalled windows
  • I've checked temperatures when running the games (they seem normal)
  • I've checked part utilization when running the games (also seem normal)
  • I've run System file checker on both of my drives
  • I've run CHKDSK on both of my drives
  • I've Defragmented both of my drives
  • I've reinstalled all the games in question
  • I've rebooted my PC upwards of 15 times
  • I've scanned for malware
  • I've prayed
So far nothing has worked and I don't know what else I can possibly try or what I'm even supposed to look for anymore. The only thing I can remember changing in my pc's inner workings is that I've upgraded my GPU driver recently, but as I've stated above, I've done a clean driver reinstallation twice already with no effect.

Please help me.
 
Last edited:

ASK THE COMMUNITY