[SOLVED] System is not recognizing my SSDs and is probably not bandwidth optimized

Sep 27, 2021
4
0
10
0
Hi All. New member and first post. I'm struggling with my setup, trying to get all my components recognized. My system is basically set up as follows:

Motherboard: MSI MEG Z490 Godlike, newest bios version installed
PCI-E1, Gen 3 populated with Nvidia RTX 3080 GPU, running at x8
PCI-E2, Gen 3 populated with MSI M2 Xpander card with Samsung 980 PRO NVMe SSD, 1TB, but neither the SSD nor even the Xpander card are recognized by the system
PCI-E3, empty
PCI-E4, Gen 3 populated with second Nvidia RTX 3080 GPU, running at x1
M.2_1 connector populated with my C: drive Samsung SSD 970 EVO, 500GB
M.2_2 connector populated with Samsung SSD 970 PRO, 1TB
M.2_3 connector populated with Samsung SSD 970 PRO, 1TB

My issue is that only the C: drive and the 2 GPUs are being recognized. None of the other SSDs or the Xpander card are being recognized in Windows 10. The motherboard explorer in bios sees the SSDs but not the Xpander card.

I guess at a minimum I'd like to have my GPUs running with the maximum bandwidth possible, and to have that Samsung 980 PRO SSD running at Gen 4 speed. The SSD running as my C: drive is fine as it is.

Any ideas where I can start? I'd be happy to provide any other specs/details as needed. Link to photo of system is below.

Thanks for your help,

Photo of system

-George
 

jojesa

Illustrious
Go to Settings>Advanced>Integrated Peripherals>SATA Mode and change from AHCI to RAID.
Go to Settings>Advanced>Windows OS configuration and change Windows 10 WHQL Support to Enabled.
Save settings.
Go to Settings>Advanced>Virtual RAID on CPU>All Intel VMD Controllers.
There you will see the SSD listed.

The i9-10900K does not support PCIe Gen 4, so the Samsung 980 PRO SSD won't be running at Gen 4 speed.

You should use the 1TB Samsung 980 PRO NVMe SSD, on the motherboard M.2_1 or M.2_2 slots.

Install the 2x 1TB Samsung SSD 970 PRO, on the MSI M2 Xpander card, on RAID, since the main purpose of that card is to run SSDs on RAID mode.
 
Last edited:
Sep 27, 2021
4
0
10
0
Did you happen to configured the BIOS by enabling PCIe Gen4 and RAID.

Which CPU do you have?
I think you need 11th Gen Intel CPU for PCIe Gen 4
Hi Jojesa. Thanks for your reply. I do not have RAID enabled, but I did set my PCIe to Gen 4. My CPU is an i9-10900K.
 

jojesa

Illustrious
Go to Settings>Advanced>Integrated Peripherals>SATA Mode and change from AHCI to RAID.
Go to Settings>Advanced>Windows OS configuration and change Windows 10 WHQL Support to Enabled.
Save settings.
Go to Settings>Advanced>Virtual RAID on CPU>All Intel VMD Controllers.
There you will see the SSD listed.

The i9-10900K does not support PCIe Gen 4, so the Samsung 980 PRO SSD won't be running at Gen 4 speed.

You should use the 1TB Samsung 980 PRO NVMe SSD, on the motherboard M.2_1 or M.2_2 slots.

Install the 2x 1TB Samsung SSD 970 PRO, on the MSI M2 Xpander card, on RAID, since the main purpose of that card is to run SSDs on RAID mode.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS