System just died last night

acm1979

Prominent
Dec 31, 2017
4
0
510
0
Custom built rig, been running perfectly for 18 months now, last night mid gaming session it just goes dark. No warning, nothing, just shuts down. Power button does nothing. Slight burny smell coming from it, no smoke. Unplug power and pop open case, no smoke anywhere. I plug it back in and hit power, very brief momentary flash of power for case fan LEDs and then instantly dark again. Power button does nothing again.

I stripped the whole thing down to components. Drives, CPU, fans, RAM, GPU, everything. No visible signs of damage or shorts. Reseated every connection and cable. Same thing. At this point I'm thinking it is likely a power supply issue.

I have an ASUS 970 Pro Gaming Aura motherboard and it has LEDs on it that color change under the southbridge chipset and along the back plate. My GPU also has LEDs on it for display. When I turn the PSU's power switch on, both of these are getting power and lighting up. But the PSU fans never turn on and when I hit the case power switch there is that momentary flash of power to the case fan LEDs and then nothing, though the mobo and gpu stay lit. Power switch remains dead unless I turn off the PSU and turn it back on.

PSU is a Kentek 700 W. Model: GL-PSPK700B. Reading last night it seems this is a no name PSU and perhaps not the most reliable out there.

Any ideas or things I might be missing? I have the skill level to build a rig without issue, but troubleshooting an electrical issue is something I've never had to do before, so if you have suggestions there, please be detailed. Thanks ahead of time everyone!
 

marksavio

Estimable
Dec 23, 2017
1,679
2
2,960
420
sounds like a short or your mobo didnt shutdown on time on critical temps. fans/heatsinks not working properly anymore. remove all dust from them now. to try to salvage it. how about just attach your display cable to your mobo. remove your gpu. remove all ram except one. remvoe all usb. and run. and see if you can access your mobo. yah if you cant powerup, its your psu then. like the guy below me said.
 

dudio

Admirable
Apr 26, 2015
2,243
5
6,965
463
The way it shut down, and what you describe, I'd be very suspicious of the PSU.
Some computer shops will test it for free, but I'd be tempted to replace it regardless.
Take it out and smell it .. chances are that's where the electrical smell is coming from.
 

acm1979

Prominent
Dec 31, 2017
4
0
510
0


I had actually just done a complete case dusting 4 or 5 days ago so it was very clean. CPU and case fans were all working (either have LEDs on them or are visible through side panel). The only fans I couldn't see were the 2 on the PSU. I can't hook display directly to the mobo as there is no onboard GPU, but I can certainly try removing it and seeing if it will get past the power on stage. That would clear that up anyway.
 

acm1979

Prominent
Dec 31, 2017
4
0
510
0


I didn't get a chance to smell it right after it happened, I was looking for the problem elsewhere. By the time I started thinking about PSU the smell had dissipated. My initial thoughts were the CPU. But I just feel it's a PSU issue and I will certainly call some computer places and see if any will test. Read a how to on using a multimeter to do it, but just seems a little above my level of expertise. Stupid holiday weekends. :D Thanks!
 

acm1979

Prominent
Dec 31, 2017
4
0
510
0


Thanks for validating my thinking. Haven't ever had a system do this before and given PSU on bottom of case, fans on top, my initial thought was the CPU. By the time I checked it and had stripped components out the smell had dissipated or I'd have sniffed the PSU. But I just feel that's what this is. Going to find a place that will check it out and purchase a more expensive better known brand this time.
 

ASK THE COMMUNITY

TRENDING THREADS