Question Thinkpad with no Internal HDD, but have SSD in DVD Drive Caddy, wont boot unless WinXP Bootable USB Flash Drive is plugged in

Feb 15, 2023
Hello Everyone,

Have an issue I hope someone can help me with.
Ive searched the forum and saw a couple of similar problem with an SSD in a DVD drive caddy not being able to boot, but my situation is a bit different.

Recenty got a used

Intel i5 2.5ghz
128gb INTERNAL SSD running Windows 10

I bought this to put a CLONED WINDOWS XP HDD on it.
(Or, as a backup plan, replace the 128gb SSD with a bigger capacity SSD for Win10 use)

The problem is when I opened up the bottom and tried to remove the SSD , it was stuck with a strong double sided tape that I needed to apply strong force to remove it, and the CONTROLLER BROKE. (oopss.. I swap out disks all the time and this is the first time this happened to me)

I figured that out when I replaced the SSD with a different drive and it didn't plug in properly, nor can I return the old SSD back.

Booting the unit will say

Realtek PCIe GBE Family Controller Series v2.35 (06/14/10)
PXE-E61: Media test failure, check cable

Thankfully, this unit comes with a DVD Drive bay (empty as it turned out)
So my solution is to use a Drive Caddy (I temp borrowed the 11.5 mm one I have on one of the laptops here and I ordered a 12.7mm online )

Its now using the bnew 12.7mm Caddy, and I tried 2 different SSDs. The problem is this:

1. I made a Windows XP Installer on a USB Flash drive and Booted it, Successfully Installed WinXP on the SSD in the Drive Caddy.

But the USB Flash Drive needs to stay plugged in to boot to XP.
Otherwise it will have the "Media Test Failure" error and wont boot.

You can also see the SSD is detected in the startup screen, it just wont boot without the WinXP USB Flash drive.

Booting with the Flash Drive will show the "Press a key to Boot to USB"menu , I ignore it and it will proceed to boot XP properly.

After which I can remove the USB Flash Drive and use WinXP normally...until I reboot or Start again.

2. I then made a Windows 10 Installer on a USB Flash Drive and tried to install it.
After initial setup, it reboots back to the USB, but unlike the XP Boot drive with a "Press a key" menu, it just goes back to the INSTALL WINDOWS 10 32 bit or 64 bit Menu and wont proceed to setup.

So what I tried was, I took out the Win10 USB and put in the WinXP USB and on reboot, it asks
"Press any key to boot to USB" I ignore it and waited, and it proceeded to boot to the SSD in the Caddy to continue its Win10 setup.

So now its running Windows 10 perfectly,, but I need to put the Windows XP Flash drive in the USB with every boot up or restart.

To recap, BOTH Windows XP, and Windows 10, needs to have this WinXP Bootable USB Flash Drive plugged in.

Things Ive Tried already:

  1. Did the Boot Menu Order properly (it detects it as ATAPI CD0)
  2. Updated the BIOS (the latest is Aug 2013)
  3. Tried to tweak BIOS
  4. Used EASEUS Partition Manager WinPE Bootable USB to "Fix MBR", thinking it might be that.
  5. plus tried other things ive seen suggested in the forums.

Still wont work. Im stumped. Does anyone have any ideas?
Could the broken Controller have anything to do with this?
I guess the worst case scenario is to just have the windowsXP Bootable flashdrive permanently pluuged in there.

Thanks in advance for any feedback or comments :)

P.S. Ive been in TH before, last login was over 10 years ago and I cant remember my old username :)