Question Trying to figure out if my GPU or PSU is the problem ?

Apr 8, 2022
5
0
10
0
Hello, I bought a used 2080 super recently, and I've been getting black screens when running some in-game benchmarks for 1-5 mins.
this used to require me to switch my psu on and off in order to boot. but after using DDU to uninstall old amd gpu drivers and reinstalling the current ones, the power button works fine again
I hold it to turn the fans off after the black screen, and press it to boot again.
furmark ran completely fine for over an hour before I manually stopped it, heaven ran for 10 minutes then blackscreen. also for example AC odyssey's in-game benchmark caused the black screen in under 5 mins.
Basically, I'm trying to figure out if I've been scammed on the gpu or if my psu is on it's last legs
I used my psu to mine eth for about a month which resulted in its baring becoming noisy, it's 700w 80+ gold, had it for about 3 years. But it also ran fine with my rx580, however it could be that the rx580 simply required less power and my beat up psu could handle it. Also it's event 41 in the event viewer if that helps at all.

My specs are:
GPU: Gigabyte RTX 2080 super
CPU: Ryzen 5 2600
Ram: 16GB 2400
Motherboard: B450M s2h
PSU: 700watt 80+ Gold
 
Apr 8, 2022
5
0
10
0
Hello, I bought a used 2080 super recently, and I've been getting black screens when running some in-game benchmarks for 1-5 mins.
this used to require me to switch my psu on and off in order to boot. but after using DDU to uninstall old amd gpu drivers and reinstalling the current ones, the power button works fine again
I hold it to turn the fans off after the black screen, and press it to boot again.
furmark ran completely fine for over an hour before I manually stopped it, heaven ran for 10 minutes then blackscreen. also for example AC odyssey's in-game benchmark caused the black screen in under 5 mins.
Basically, I'm trying to figure out if I've been scammed on the gpu or if my psu is on it's last legs
I used my psu to mine eth for about a month which resulted in its baring becoming noisy, it's 700w 80+ gold, had it for about 3 years. But it also ran fine with my rx580, however it could be that the rx580 simply required less power and my beat up psu could handle it. Also it's event 41 in the event viewer if that helps at all.

My specs are:
GPU: Gigabyte RTX 2080 super
CPU: Ryzen 5 2600
Ram: 16GB 2400
Motherboard: B450M s2h
PSU: 700watt 80+ Gold
 

ASK THE COMMUNITY

TRENDING THREADS