Question Two different graphics cards, neither work with DisplayPort

Apr 23, 2020
3
0
10
0
I can't make displaypory work no matter how much I use different drivers, check for firmware updates, play with power settings/display settings within windows. Best I get is a flickering mess. Only thing I genuinely haven't tried is a new cord (all 3 of mine don't work).

My PC is:
Ryzen 9 3900
Crosshair VIII Formula
32GB Trident Z Royal 3200Mhz
Windows 10
Graphics cards are:
Gigabyte Aorus RTX2080 Super
Radeon 5700XT

My Monitors are:
2x ASUS ROG SWIFT PG279Q

Please help, I'm going crazy just trying to use my 144hz :(

I have spent way too many hours trying to get this to work, reading forums etc
 
have you tried each display separately?
have you tested the displays on another system?
do the displays have HDM or DVI inputs? if so, do they function with these options even if not at their full 144Hz?

i would also try removing every trace of existing Nvidia drivers & settings with DDU and reinstalling only the latest Nvidia driver package.
 
Apr 23, 2020
3
0
10
0
have you tried each display separately?
have you tested the displays on another system?
do the displays have HDM or DVI inputs? if so, do they function with these options even if not at their full 144Hz?

i would also try removing every trace of existing Nvidia drivers & settings with DDU and reinstalling only the latest Nvidia driver package.
I have tried both individually, I've tried all 3 DPs on both GPUS, and both GPUs work with HDMI. I've done DDU multiple times, when switching the cards over. Done fresh installs through windows etc. The only thing I haven't tried out of your recommendations is a different system on the same displays, cause I don't have access to another system unfortunately.
 

ASK THE COMMUNITY

TRENDING THREADS