Question Unable to boot from thumbdrive containing Windows setup

Jan 2, 2021
1
0
10
0
Hello, I just completed my build in an H510 with the following parts:

B550 Aorus Pro AC
Ryzen 5 5600X
Asus Dual OC RTX 3070
WD Black SN750 (1 TB)
TridentZ RGB 16 GB (DDR4 3600 MHz)
Masterliquid ML240L V2
G.Skill MB750G PSU

I turned my PC on and was easily able to access the BIOS with all of my parts listed there. The next thing I did was I used Windows Media Creation Tool to flash Windows onto an empty 16GB thumbdrive. I plugged the thumb drive into the back USB port on my PC and restarted it. When I re-entered the BIOS, I found the UEFI and USB versions of my thumbdrive in the Boot options, along with my SN750. I changed the boot prioritization to:
1.) UEFI
2.) SN750
3.) USB

I then exited the BIOS and booted my PC but got stuck on the Aorus logo indefinitely (similar to this image): https://external-preview.redd.it/-xKpOIIf_xyZ5QJn9pGGfTQXJEhodS48UEyzNz2W0mM.jpg?auto=webp&s=902331f369c306c850e6ffb90af69115c1e3793f
I tried enabling and disabling CSM in the BIOS to no avail (and I had the same results when enabling/disabling secure boot). The next thing I tried was prioritizing my USB to boot off of. I got better results with the computer showing the Windows logo but without a loading indicator (PC is indefinitely stuck here too). I really am not sure what to do anymore because it feels like I’ve tampered with the BIOS settings a hundred times now. I’ve even tried using a different thumbdrive but that didn’t work either.
Any help would be appreciated! I can provide screenshots or any additional information upon request.
 

popatim

Titan
Moderator
Btw- when you go to install windows, leave your bios boot device set to whatever will be the boot drive. Only have this 1 drive plugged in when you install windows.
Then save and power off.
plug in your flashdrive
power back on.
Press the boot option/override key (it will tell you which key to press at the bottom on the same screen that it says press Del to enter setup)
select your uefi flash drive (which may show up as something like "Windows" instead)
 

ASK THE COMMUNITY

TRENDING THREADS