Question Unable to boot with SSD plugged in - possibly SSD or motherboard issue

TrMark

Honorable
Dec 2, 2013
8
0
10,510
0
This is a weird issue, I'm not even sure what component is causing it and I can't find anyone else with a similar issue.

A few weeks ago I rebooted my computer and was given the "No OS found bla bla bla connect a device with an OS" or whatever it says. I then rebooted and tried to enter the bios to make sure my main SSD with windows was detected, but when I tried, my keyboard wouldn't initialise so the keypress to enter the bios wasn't recognised.

After some tinkering, it turns out that I have to unplug my SSD and then boot the computer for the keyboard to initialise so I can then enter the bios. From there, I have to plug in the SSD and reboot again. Only now the keyboard does initialise and lets me into the bios. I then have to change the boot order so my main SSD is first and restart once again which then boots into windows.

I've tried a new sata cable for the SSD and tried different slots on the motherboard with the same result. The motherboard I have is the MSI Z97-G45 Gaming and my SSD is a Crucial MX100 512GB.

Does anyone have any kind of insight into what may be causing it or what to try to fix it?
 
if the SSD is now locking up the computer every time you power on, or, is consistently requiring multiple resets to be detected in the BIOS, perhaps the rare SSD failure has actually struck...(as you've already tried mutiple SATA data cables and SATA ports, we can rule out any Tom-foolery tripping us up there)

You will know for sure if the SSD is bad once you've swapped it...fortunately, the MX500 is now $59 for 500 GB model, with 1 TB models at only $119...; grab yer credit card! :)
 

ASK THE COMMUNITY