Up to 3 BSOD a day.

Nov 14, 2018
1
0
10
0
Over the past month I've been getting a variety of BSOD, most of the time they would involve me playing a game, such as Conan Exile or PUBG. However recently they've started to become frequent when I exit a game or when I'm watching something.

PUBG used to cause my system to Bluescreen from just being installed, when I uninstalled it I had respite from BSOD for awhile.
Conan Exiles is prone to crashing, and often when it would crash it would be followed with a bluescreen.

These are the errors I keep seeing: (I can't remember exact wording)
Memory Management
Page Thread Exception
System Service Exception

I got these and went through and updated all my drivers. However I still got BSOD but I cannot remember the code. So I reset my windows, after scanning my files for errors, updating drivers, and scanning memory for faults.

Recent two were: (These were after I reset windows)
irql_not_less_or_equal
worker_thread_returned_bad_irql

System Specs:
OS: Windows 10 64-bit
RAM: 16gb DDR3
Motherboard: ASUSTeK Sabertooth 990fx R2.0
Graphics: GeForce GTX 1060 6GB (Gigabyte)
CPU: AMD FX-8350 Eight-core

I've included the three last minidumps here:
https://1drv.ms/f/s!ArL1mR6LJ3VKg2LW3SoYFeXpIbiX
 

ChumP

Distinguished
You should run a memtest86 first.

Memtest86 Download

Make a bootable drive and let the test run for a couple of houra... if it gives any errors in the proccess that means that your modules are faulty.
You should test every module separately with it after that to see which one of them is the faulty one
 
generic svchost.exe terminated a thread, when the system went to clean up the threads virtual memory usage (memory paged to pagefile.sys ) the virtual address that was to be release back to the system was bogus even though it looked like a valid address. This could mean the address had a bit corruption in it.

I can not read the bios info from the memory dump. this could mean a outdated bios version

looks like an amd cpu, cpu family 15, model 2, stepping 0 running at 4013mhz

try and update the bios, or reset it to defaults and reconfigure if it is already up to date.
the windows cpu microcode patch looks like it is having issues:
\SystemRoot\system32\mcupdate_AuthenticAMD.dll ***** Invalid
you might update the bios, then boot windows and run cmd.exe or powershell as an admin then run
dism.exe /online /cleanup-image /restorehealth

not sure if it will repair that file. you should also run windows update to make sure the files are current.

not sure why you would have a generic service calling terminate process.
(there are so many generic services it is hard to tell which one is making this call)

since this bug is in virtual memory, you might want to go to the motherboard vendors website and update your sata drivers.

you might also download and run memtest86 to confirm your memory timings are correct. (update bios first, since you will have to update anyway if any errors are detected)

check your motherboard vendors website for update motherboard sound drivers. your version is 2 months before a certain fix was released.

if the problem is in the storage driver it would be this file:
Asmedia 106x SATA Host Controller Driver
SystemRoot\System32\drivers\asstahci64.sys Mon Aug 21 00:54:07 2017
update from the motherboard vendor website
or directly from here: http://www.asmedia.com.tw/eng/e_products_list.php?item=83&cate_index=0
this driver will depend on the bios version you have installed, if your bios is too far out of date the driver might not work correctly.

but you have to go to your motherboard specs and find the tech specs for the chip number for the asmedia host controller chip.

you could also just move your drive data line from the asmedia host controller to the primary sata controller on the motherboard. The other controller is slower but is less likely to have bugs since it is updated by windows update


 

ASK THE COMMUNITY