Upgraded Ram now PC wont turn on.

Sep 17, 2018
1
0
10
0
So I bought a prebuilt computer

(This is the one I purchased CYBERPOWERPC Gamer Xtreme GXIVR8020A5 Desktop Gaming PC (Intel i5-8400 6 Core Processor, AMD RX 580 4GB, 8GB DDR4 RAM, 1TB 7200RPM HDD, WiFi, Win 10 Home 64-bit), Black - VR Ready https://www.amazon.com/dp/B07B6H4GNY/ref=cm_sw_r_cp_apa_TTaOBbBWP8EWJ)

And I recently wanted to double up the ram for a few titles i want to play, bought the EXACT same ram currently in the computer. Team T- Force Vulcan 8gb DDR4. came in the mail today was super happy (came in 4 days early.) Snapped it in easy peasy made loud click and everything. booted it up and it was still only registering 8 gigs, so turned it off and popped the ram back out to make sure it wasnt bent or anything. Nope 100% okay. tried again. still only showing 8 gigs.

So I try popping out the old one and reinserting it to make sure it was making the same sound (I'd never tinkered with the ram when I swapped out of the original case to my current case) sure enough it did. But now my computer wont boot up so I'm assuming it's now not even registering the original stick of ram. any suggestions? Really at a loss for what to do.
 

gingerrankin

Reputable
Apr 3, 2018
783
19
5,815
218
Make sure they are firmly in place. Sometimes you have to open a tongue. Sometimes it costs a little to enter. Try starting with just one.

Make sure that when you remove and put the RAM you have not moved the graphics card, its power cables and the power cables of the mobo.
 

gingerrankin

Reputable
Apr 3, 2018
783
19
5,815
218
Make sure they are firmly in place. Sometimes you have to open a tongue. Sometimes it costs a little to enter. Try starting with just one.

Make sure that when you remove and put the RAM you have not moved the graphics card, its power cables and the power cables of the mobo.
 

ASK THE COMMUNITY