Question USB wifi adapter losing signal when plugged in back!

Imz Deodex

Honorable
Oct 15, 2014
100
0
10,680
0
Please help me! I have this TP-LINK Archer USB wifi adapter... it is behaving really weird. Everytime I plug it at the back of my PC... it loses 50% of its strength and my download speed is cut in half!
But when I plug it on the front panel... MY SPEED IS BACK TO NORMAL! could this be interference? I have many cables plugged at the back of the Mobo
 

arif1752002m4a1

Respectable
May 16, 2018
740
19
2,565
108
Please help me! I have this TP-LINK Archer USB wifi adapter... it is behaving really weird. Everytime I plug it at the back of my PC... it loses 50% of its strength and my download speed is cut in half!
But when I plug it on the front panel... MY SPEED IS BACK TO NORMAL! could this be interference? I have many cables plugged at the back of the Mobo
Wifi signals are not good enough to penetrate steel.(cabinet) but they get absorbed by wall.. so if we plug Wifi adapter in back of the computer.. then Weak wifi card starts to loose their signals.. that's why I recommend to use internal wifi card..on PCIe card.. those have good range.. and have better stability.. they don't heatup... And many more things..

You should get a USB hub.. and plug Wifi card into it.. and place it on top of the case.. that will give you best results
 
Reactions: Imz Deodex

Imz Deodex

Honorable
Oct 15, 2014
100
0
10,680
0
Wifi signals are not good enough to penetrate steel.(cabinet) but they get absorbed by wall.. so if we plug Wifi adapter in back of the computer.. then Weak wifi card starts to loose their signals.. that's why I recommend to use internal wifi card..on PCIe card.. those have good range.. and have better stability.. they don't heatup... And many more things..

You should get a USB hub.. and plug Wifi card into it.. and place it on top of the case.. that will give you best results
yes this explains it! my front usb panel is already on top of the case. It is an NZXT H500. I tried multiple usb ports at the back but same results! the only way it gets fixed is when I use the top front usb hub
 

arif1752002m4a1

Respectable
May 16, 2018
740
19
2,565
108
yes this explains it! my front usb panel is already on top of the case. It is an NZXT H500. I tried multiple usb ports at the back but same results! the only way it gets fixed is when I use the top front usb hub
Yes.. or use very powerful wifi adapter.. or get an internal wifi card...
Both will fix the issue.. or just simply Install your current card on USB hub on the top of case or on table
 

ASK THE COMMUNITY